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Before you start using the software, we recommend that you 

understand the BES Blue design workspace and learn a few of the 

basic components outlined in this section.

Topics covered in this chapter:

• Setting up the design workspace environment.

• Showing a hoop in the workspace, and choosing the size of hoop to 

be displayed.

• Creating your own customized hoop.

• Using the online help.

CHAPTER 1:

Learning about the 
Workspace
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Parts of the Workspace
The BES Blue workspace contains a number of different areas which 

have distinct functions. The sections that follow give an overview of 

what each of these areas does, and the kinds of information about the 

design that they contain.

Title Bar
The Title Bar appears at the top of the BES Blue design window. The 

Title bar displays information about the design that is open in the 

workspace: its name, the number of stitches and colors in the design, 

and the overall width and height.

Accelerator Button
At the top left-hand corner of the design workspace you will find the 

Accelerator button . Clicking this button gives quick access to a 

menu of useful tools including the New, Save, and Print tools, plus 

several others. For a complete list of the tools available on this menu, 

and a summary of their functions, see “Accelerator Menu Tools” in the 

next section. 
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When you open the Accelerator Menu, you will also see displayed a 

list of recent files that you have been using. Just double-click on the 

file name to open it.

Tools available on the Accelerator Menu
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Quick Access Toolbar
The Quick Access Toolbar is located right along the top of your 

workspace, to the left of the Title Bar. This toolbar contains tool 

buttons that you will commonly use, such as Open, Save, and Print; 

but it is fully customizable, meaning that you can add the tools you 

personally use most often, for easy access. See “Customizing the 

Quick Access toolbar.”

To start out, the following default tools are included on the Quick 

Access toolbar: New, Open, Save, Send to Machine, Print, Undo and 

Redo. 

Customizing the Quick Access Toolbar

One important advantage of the Quick Access toolbar is that it is fully 

customizable. This means that you are able to select tools from any of 

the toolbars and add them to the Quick Access toolbar. You do this by 

way of the Customize function, which is accessed by clicking the small 

down arrow to the right of the Quick Access toolbar.

To customize the Quick Access toolbar:

1 Click the down arrow at the right end of the Quick Access toolbar.

You see a menu.
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2 Click on More Commands...

You see the Customize dialog.

3 From the “Choose Commands from:” list, select the toolbar 

containing the command you want.

The list of tools on that toolbar now appears in the “Commands” box.

4 Select the desired tool from within the “Commands” box, and click 

Add.

The selected tool appears in the list of Quick Access Toolbar tools.

5 Repeat steps 3-4 until you have added all the tools you want to the 

Quick Access Toolbar.

6 If there is a tool on the Quick Access Toolbar that you do not want 

to have on there, select it in the right-hand box and click on the 

Remove button in the dialog.

7 When you have added and/or removed all the buttons you want, 

click OK.

The dialog will close; the Quick Access Toolbar will be changed 
accordingly.
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Adding Separators in the Quick Access Toolbar

You have the option of also adding separators in the Quick Access 

Toolbar. These are small vertical marks which appear on the Quick 

Access Toolbar, and divide the commands into groups for ease of use. 

A separator is added just the same way as you add commands; select 

<separator> in the “Choose commands” list and then click the Add 

button. 

Here is an example of how the separators work. If you create an 

arrangement of separators and commands in the Customize dialog 

that looks like this:

The Quick access toolbar will be organized to look like this:

For more details, see the procedure outlined above, “Customizing the 

Quick Access Toolbar”.

You can change the position of a separator, or any command in the 
Quick Access Toolbar. Select it in the box to the right in the Customize 
dialog, and click the up and down arrows on the right. This will move 
the command or separator relative to the other commands in the Quick 
Access Toolbar.
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Customizing Keyboard Shortcuts

Another useful feature of the More Commands menu item (on the 

Quick Access Toolbar) is that it gives you the option of assigning your 

own custom keyboard shortcuts. Keyboard shortcuts can be very 

useful for those tools that you use most often.

To assign keyboard shortcuts:

1 Click the down arrow at the right end of the Quick Access toolbar.

You see a menu.

2 Click on More Commands...

You see the Customize dialog.

3 Click the Customize button.

You see the Customize Keyboard dialog.
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4 From the “Categories” list, select the category containing the 

command you want.

The corresponding list of commands appears in the “Commands” 
box.

5 Select a command to which you would like to assign a shortcut.

6 Click in the “Press new shortcut key” field.

7 On your keyboard, press the sequence of keys that you want to 

use; these keystrokes will appear in the field.

8 Click the Assign button to create the custom shortcut.

The shortcut sequence will be moved into the Current Keys field.

9 Repeat steps 3 - 8 until you have created all the desired keyboard 

shortcuts.

10 Click close.

If there are two or more keys used in the shortcut, a plus sign (+) will be 
inserted between them, to indicate that they are to be used in 
combination. The (+) on your keyboard is not part of the shortcut 
sequence.
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Toolbar and Ribbon Buttons
You can access the tools available in BES Blue through the 

Accelerator button  or the tabs.

The tables below show the buttons, grouped by their place in the 

workspace. A brief description of what the button does is also 

included. Note that within each tab, some buttons are grouped 

together by function.

Accelerator Menu Tools

Tool What it means

New: Creates a new, untitled design.

New Project: Opens a new page and allows you to choose the 
name, recipe and machine format.

Open: Opens an existing design file.

Merge: Opens the Merge Design dialog, which you can use to 
import existing stitch or outline files into the current design.

Browser: Opens a Browser window, a dialog box which allows you 
to search all your computer’s disks and directories for design files.

Save: Saves the current design.

Save As: Opens the Save As dialog, allowing you to choose the 
destination and file type to save it as.

Import FCM: Browse for *.FCM (cutter artwork) files and import 
them directly into the workspace.

Export Image: Creates an image file based on the current design, 
which can be saved as a *.bmp, *.jpg, or *.png file.

Export SVG: Exports the current design as a vector graphic image 
file.
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Extra Tools

Export FCM: Exports the current design as an *.FCM file, which can 
be imported directly into a Brother ScanNCut machine for appliqué 
cutting.

Print: Opens the printer dialog on your computer, allowing you to 
choose your printer and adjust the printer’s properties. 

Direct Print: Prints a copy of the design worksheet, bypassing the 
printer dialog.

Print Preview: Opens the print preview window, which in turn will 
let you print the current design.

Print Setup: Opens the print setup dialog, which allows you to 
select the printer, and to modify print properties.

Close: Closes the file that you are currently working on (the active 
file) leaving any other files open. 

Close All: Closes all files that are open on your computer. 

Restore last Autosaved: Opens the last file saved by the 
Autosave feature. The frequency at which files are Autosaved can 
set on the Environment tab of the Preferences page; the default 
setting is 5 minutes.

Exit: Closes all open files and shuts down BES Blue; you will be 
prompted to save any open files.

Tool What it means

Undo: Reverses your last action.

Redo: Reverses the action of the Undo command.

Tool What it means
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Ribbon Tools
The Ribbon appears below the Title Bar. The Ribbon has file tabs, the 

Home tab, the Arrange tab, the Tools tab, and the View tab. Clicking 

on the tabs displays all the buttons for the functions that are under that 

tab.

Tools on the Home Tab

Tool What it means

Select: Selects objects in the design window.

Select All: Accessed via the drop-down menu from the Select 
tool.Selects all items in the design workspace.

Cut : Cuts the selection and copies it to the clipboard.

Copy: Copies the selection to the clipboard.

Paste: Pastes the clipboard contents into the design, at the end 
of the design sequence.

Insert: Pastes a copy of the clipboard selection into the sewing 
sequence immediately following the selected segment. 

Delete: Removes the selected segment.

Text: Creates lettering placed along a straight baseline.

Path Text: Creates text segment along a path. The path may be 
chosen from a pre-defined list of shapes, or you may create your 
own shape.

Follow Path: Creates text segment along a path. The letters of 
the text will be evenly distributed along the length of the path.

Vertical Frame: Creates vertical lettering.
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Circle Frame: Creates lettering based on a circular baseline.

Monogram Frame: Creates three-letter monogram text.

Step Text: Creates a lettering segment in which the individual 
letters descend (or ascend) in a step-wise fashion.

Spiral Text: Creates a text string in a spiral shape.

Name Drops: Quickly create a number of distinct designs, 
based on a single design, but each with different text string 
included. 

Monogram Designer: Opens the Monogram Designer dialog, 
for creating custom monograms with decors and/or frames.

Alpha Mapping: Opens the Font Creator wizard, which you can 
use to create custom fonts from individual embroidery files.

Add Design: Adds decorative features to your design - accents, 
appliqués, borders, and frames.

Auto Baste: Automatically adds an outline of basting stitches 
around the current design.

Color Sort: Automatically reduces the number of thread 
changes that are required in a design, by re-arranging the 
sewing sequence so that like colors are together.

Add Notes: Allows you to insert (non-printing) text notations into 
the design.

3D: Realistically renders your design onscreen.

Grid: Displays a background grid, which helps with alignment. 
This grid can be used for the alignment of items on the display.

Hoop: Displays the hoop as it fits relative to the embroidery. 
Clicking this button a second time will turn the view of the hoop 
off. 

Tool What it means
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Select Hoop: Accessed via the drop-down menu from the Hoop 
tool. Opens up the Select Hoop window, in which you can 
choose a new hoop.

Fit Hoop: Accessed via the drop-down menu from the Hoop 
tool. Scales the design up to the maximum size of the selected 
hoop on the design window.

Background: Two options are available from this button, Select 
Color or Select Fabric. Depending on which one you choose, a 
dialog box will open in which you select either the color, or the 
fabric pattern, that appears in the background of the active 
design window.

Ruler: Measures the distance between any two points in a 
design.

Zoom: Magnifies the design to fit a rectangle drawn by the user 
with the mouse pointer.

Zoom in: Magnifies the view of the design by a fixed amount.

Zoom out: Shrinks the view of the design by a fixed amount.

Fit to Window: Displays the entire design and loaded images in 
the window.

Back to 1:1: Returns design to original size.

Slider: Drag the slider to choose a specific level of 
magnification; displays percentage of original size.

Pan: Allows you to move the design around in the workspace 
window by clicking and dragging.

Tool What it means
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Tools on the Arrange Tab

Tool What it means

Select: Selects objects in the design window.

Select All: Accessed via the drop-down menu from the Select 
tool. Selects all items in the design workspace.

Distort: Displays the Distortion dialog, which you can use to add 
interesting effects to the selected design.

Align Left: Aligns all selected objects with the left-most item 
selected.

Align Right: Aligns all selected objects with the right-most item 
selected.

Align Top: Aligns all selected objects with the top-most item 
selected.

Align Bottom: Aligns all selected objects with the bottom-most 
item selected.

Horizontal Center: Takes all selected objects and centers them in 
the selection box. The objects are moved so that they are 
centered left-to-right with each other, but they are not moved up or 
down.

Vertical Center: Takes all selected objects and centers them in 
the selection box. The objects are moved so that they are 
centered top-to-bottom with each other, but they are not moved 
left or right.

Center: Centers one or more selected objects proportionally 
within the current hoop. If more than one object is selected, the 
entire group is moved together to the center of the hoop; the 
objects selected remain in the same position relative to each other 
as they had before being centered.

Distribute Horizontal: Distributes objects evenly in the horizontal 
direction.

Distribute Vertical: Distributes objects evenly in the vertical 
direction.

Flip Horizontal: Flips one or more selected objects horizontally.
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Tools on the Tools Tab

Flip Vertical: Flips one or more selected objects vertically.

Rotate Left: Rotates one or more selected objects to the left by 90 
degree increments.

Rotate Right: Rotates one or more selected objects to the right by 
90 degree increments.

Rotate: Opens the Rotation dialog, which allows you to enter the 
exact number of degrees of rotation to apply to the selection.

Tool What it does

Select: Selects objects in the design window.

Select All: Accessed via the drop-down menu from the Select tool. 
Selects all items in the design workspace.

Arrange on Path: Creates a repeated pattern based on a selected 
design element, which a pre-determined path that you can select.

Arrange on Circle: Inserts a circular arrangement of small 
elements (based on the selected artwork or design) into the current 
design.

Arrange on Corner: Automatically creates a reflected, four-fold 
image of the selected segment. 

Arrange Rows: Creates a repeated pattern of rows and columns, 
based on the selected design element.

Scatter Design: Creates a random pattern of designs based on a 
selected design element.

Word Collage: Creates a random pattern of words scattered 
across a user-determined shape in the design. 

Thread Palette creator: Allows you to create your own custom 
thread palettes for use in your designs.

Batch Converter: Allows you to convert a set of design files in a 
selected folder to a different file type.

Tool What it means
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The View Tab
The controls on the View Tab allow you to change what appears on 

your workspace; which panels are displayed, whether or not 

commands and stitch points are shown in the design, and so on. The 

controls on this tab are organized into four blocks: Display, Windows, 

Show/Hide, and Program Preferences.

ScanNCut: Generates a printed template which you can use to 
scan into a cutting machine for creating appliqués.

Page Preview: Places dotted outlines on the screen in shape & 
size of the default page size. Assists in preparing Scan & Cut 
image files for printing.

Page Preview Offset: Sets the position of the upper-left corner of 
the page preview.

Export FCM: Exports the current design as an *.FCM file, which 
can be imported directly into a Brother® ScanNCut machine for 
appliqué cutting.

Line: Used to draw an artwork line into a design; allows you to 
toggle between entering straight and curved points

Close Shape: Allows you to close open shapes when working with 
the Line tool.

Edit Shape: Selects a line, and allows you to add, delete, or move 
its anchor points

Convert to Appliqué: Converts the selected outline segment to an 
appliqué segment. 

Tool What it does
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View tab tools

Windows

In the Windows area, check the box to show the corresponding 

window or panel, and uncheck it to hide that window or panel.

• Sequence: Shows/hides the Sequence view.

• Palette: Shows/hides the thread palette.

• Design Palette: Shows/hides the Design Palette, which shows 

the colors currently in use in the design.

• Properties: Shows/hides the properties panel.

• Simulator: Shows/hides the sewing simulator.

• Status: Shows/hides the status bar.

Tool What it does

Grid: Displays a background grid which can be used for the 
alignment of items in the design.

Backdrop: Click this icon to load an image into the design 
workspace, for tracing.

Background Color: Allows you to choose a color or fabric image to 
place in the background of the workspace.

Garment Templates: Opens the Garment Templates dialog – use 
this dialog to insert a garment image into the design to preview 
design against the selected color or fabric background 

 Welcome Screen: The welcome screen includes links to some 
very useful web pages: the Blog page, Projects (where you can 
download free designs), and the Support and the Events pages.

Ghost Mode: Displays any hidden segments/stitches in light gray 
color in the workspace.

Preferences: The Preferences panel allows you to adjust various 
aspects of the program including the default recipe that will be 
applied, environment settings, grid settings, and many others. 
For more details, see “Setting up the Workspace.”
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Show/Hide

Check the boxes to show the corresponding symbols in the Design 

Workspace.

• Entry/Exit: Shows the position of the first and last points in the 

sewing of a segment.

• Command: Displays icons in the workspace that show where 

the color changes and trims are.

• Stitch points: Shows the penetration points of the stitches.

Ghost Mode
In BES Blue to hide those segments that are not currently selected. 

This is accomplished by right-clicking a segment in the Sequence 

View, and selecting “Hide other” from the context menu. When you 

click the Ghost Mode  tool, you will be able to see the hidden 

segments as pale outlines (“ghosted”) while they are still in a hidden 

state. Note that hidden segments are effectively locked, and may not 

be selected or modified.

The intensity of the Ghost Mode can adjusted up and down. You can do 
this on the Environment tab of the Preferences dialog. See “Setting up 
the Workspace–Environment Settings.”
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Program Preferences

Click on the Preferences  button to open a dialog in which you can 

set the default machine settings, change the units of measure, and 

choose settings for the workspace grid. For more information on this 

dialog, see “Setting up your Workspace Environment”.

Simulator
The Simulator makes it easy to see on-screen how your design will 

sew out. You can use the Simulator to eliminate potential sewing 

problems.

When you select Simulator from the View tab of the Ribbon, the 

Simulator (scrollbar slider and the sewing simulator) will appear at the 

bottom of the design space. The Simulator controls which parts of the 

design are drawn in the design window.

Scrollbar Slider

The length of the scrollbar slider represents all of the stitches in the 

opened design. You can move the scrollbar slider by dragging it to see 

a design as it will look sewn to a particular point. The color display 

within the scrollbar indicates the thread color that will be sewn when 

the scrollbar slider is positioned over it. Clicking on the arrows at the 

ends of the scrollbar will advance or retrace the design position by one 

stitch.

Sewing Simulator

You can also open and close the Simulator by pressing Ctrl + R.
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The sewing simulator allows you to watch your design draw on a 

stitch-by-stitch basis, simulating the sewing action of your machine. 

The Simulator controls include pause, stop, sew forward and sew 

backwards. You can push various control buttons and slide the speed 

control to vary the rate of sewing.

Using the Simulator

The following table explains how to use the Simulator in more detail:

Tools What is does

Previous Stitch: Move backward in the design by one 
stitch.

Scrollbar slider: Drag the scrollbar slider to advance 
the design to a specific position. When the scrollbar 
slider is positioned over a color, you will see the 
specified thread color being sewn in the design. The 
entire length of the scrollbar slider represents the entire 
design.

Next Stitch: Move forward in the design by one stitch.

Simulate Sewing (backward): Move backward through 
the design.

Pause/Stop: Pause or stop the design while drawing. 
When you play or resume sewing your design, stitching 
will continue from the location of the last stitch.

Simulate Sewing: Move forward through the design.

Speed: Slide the speed control to vary the rate of 
sewing.

Insert Color Stop: As you navigate through the design, 
click on this button to place a color stop command.
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Status Line
The Status Line appears at the bottom of the BES Blue window. To 

show or hide the Status Line, go to the Windows area of the View Tab 

and check or uncheck Status. 

The Status Line displays the total number of segments in the design, 

the size of the hoop, the design’s recipe, and its machine format. 

When a segment is selected, it will also show the number of stitches 

contained in the selected segment and its dimensions.

Color Palette
The thread colors of the currently selected thread chart are shown in 

the Color Palette. You can show/ hide the Color Palette by checking/ 

unchecking the “Palette” checkbox on the View tab.

Using the Color Palette, you can quickly change the color of a design 

segment by selecting it, and then clicking on the color square in the 

color palette. 

For more information, see “Editing Designs—Working with the Color 

Palette.”

Design Palette 
The Design palette shows the colors that are used in the current 

design. Superimposed on each color, you will see the needle number 

corresponds with that color. When a thread color is changed in the 

design, the Design palette will immediately update to reflect the 

change.

Detail of the workspace, showing the Color Palette (top) and the Design Palette 
(below it).

You can show/ hide the Design Palette by checking/ unchecking the 
“Design Palette” checkbox on the View tab. 
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Using Scrollbars
 Scrollbars are tools in the workspace that enable you to move easily 

around within the displayed design. There are two scrollbars, one for 

moving the view vertically, and one for moving it horizontally.

How to use the scrollbars:

• To pan left/right, or up/down, click and drag the track button.

• Click on the small arrows at each end of the scrollbar to move the 

design view incrementally.

• Click in the track of the scrollbar, to move the workspace view by 

one whole screen

You can also right-click the scrollbar to display a pop-up menu of scroll 

actions. The menu displays the following options:

Correcting Mistakes
Undo and Redo are two significant features that allow you to correct 

mistakes. If you make a mistake and change your mind about an 

action you just made, Undo reverses the action. Redo puts back the 

change. If Undo or Redo are grayed out, you cannot Undo or Redo. 

To use Undo: 

• Do one of the following: 

 On the Quick Access toolbar click the Undo  tool. 

 Press Ctrl+Z on your keyboard.
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To use Redo: 

• Do one of the following: 

 From the Quick Access toolbar, click the Redo  tool.

 Press Ctrl+Y on your keyboard.

Setting up your Workspace
Certain properties of the BES Blue software - such as the grid spacing, 

or how designs are handled - can be configured on the Preferences 

dialog. Open this dialog by clicking the Preferences  button on the 

View tab.

There are several different categories of preferences on this dialog – 

Format, Environment, Grid, Auto Baste, Color Sort. The settings in 

each category will be treated separately in the following sections.

Format Properties
All designs in BES Blue have a machine format. Machine formats have 

their own profile settings that determine how embroidery information 

will be interpreted when you save design files. When you create a new 

design file, you can select the machine format for the specific design.

The selected machine format can change how the design file is read. 

When you set machine format properties in the Preferences dialog, all 

new designs will use these machine format properties as the default 

settings.

The Format tab also contains the following other settings: Hoop 

Bracket Location, Color match on loading, Autosave *.BRF Format, 

Maintain Hoop Placement on Load, and Show Hoop on New/Open.

If you open a design with the New Project command, you can select the 
recipe for the new design in the New Page dialog. This will override 
whichever recipe is set as the default in the Preferences dialog.

Changing machine format properties after a design file has been 
opened will not change the machine format of the embroidery designs 
in that design. 
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To adjust format properties:

1 On the View tab of the Ribbon, select the Preferences  button.

You see the Program Preferences dialog box.

2 Select the Formats tab; do one or more of the following:

 In the Recipe drop-down list, select which recipe will be 
applied, by default, each time you open a new design.

 From the Machine format list, select the machine format that 
you want applied to new design files.

 Hoop Bracket Location: When the hoop is displayed in the 
workspace, it will show which side the bracket is on; use this 
setting to determine the bracket’s location - top, bottom, left or 
right.

 Color match on loading: Check this box to match the thread 
colors of an existing design that you open with the thread chart 
that is currently active. 
For more details, see “Automatic Color Match” below.

 Autosave BRF Format: Check this setting to automatically 
save the open files in *BRF format.

 Maintain Hoop Placement on Load: When selected, the 
orientation and position of a design within a hoop will be 
preserved when the design is saved. When the design is 
opened again, you will see that the position of the design within 
the current hoop has been preserved. 
If “Maintain Hoop Placement on Load” is not checked, the 
design will be centered in the hoop when re-opened.

 Show Hoop on New/Open: When checked, the hoop will 
appear automatically in the design workspace when you open 
an existing design, or create a new design.

3 Click OK.

Your preferences will be changed accordingly, and the Program 
Preferences dialog box will close.
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Automatic Color Match

When you first open a design file, its thread colors will be those of the 

thread palette that was saved with the file when it was created, rather 

than the palette that is currently open. If you want to, however, you can 

convert the thread colors in a design to the current active thread 

palette, using the Color Match feature.

You activate this feature by checking the box marked “Color Match on 

loading” on the Formats page of the Properties dialog.

When you open a stitch file, “Color match on loading” will change the 

thread colors to match those in the current thread palette. The 

program searches the active palette for the closest match to the thread 

colors that are in the design, and automatically replaces them. Then, 

when you save this design, it will retain the new thread color values.

Environment Settings
On the Environment tab, you set parameters that relate to aspects of 
the workspace environment - the units of measurement used, the 
Autosave frequency, the Ghost Mode intensity, the Show BRF save 
warning message, and the display language.

Metric
The dimensions in BES Blue can be displayed in metric values. This is 
the default setting, which will appear each time you run BES Blue. It is 
generally preferable for embroiderers to use the metric values 
because many of the manufacturers of embroidery machines and 
designs use metric values.

English vs. Metric
BES Blue displays inch measurements in tenths of inches. If you think 

in inches, then you can to set the software to use the inch system. 

Open the Preferences dialog and click on the Environment tab, and 

select English from the Units list.

Color Match applies to all types of stitch files (such as *PES, *JEF, 
*SEW, etc.) However, if the design you are opening is a *.BRF (outline) 
file, it will retain its original colors whether this option is checked or not.



32 BES Blue
To set up your workspace environment:

1 On the View tab, select the Preferences  button.

You see the Preferences dialog box.

2 Click the Environment tab.

3 From the Units list, select the units of measurement you want used 

for your designs: Metric or English.

4 From the Autosave list, select how frequently you want the open 

designs to be saved.

5 Adjust the Ghost mode intensity slider to determine the visibility of 

the Ghost image when Ghost mode is in use.

For more information on Ghost mode, see under “View Tab.”

6 Show BRF save warning: This box is checked by default.

When this box is checked, and you choose to save your design in a 

stitch format, the software will check to see if there is a saved 

outline (BRF) version of the file you are saving. If not, it will display 

a warning message, asking if you want to save this file in outline 

format first. If you uncheck BRF Save warning, this warning dialog 

will not appear, and the design file will close without prompting you 

to save in BRF (outline) format.

7 From Language drop-down list, select the language you want for 

the User Interface.

8 When the “Show warning for large satins” setting is enabled, a 

warning message will appear whenever you create a Satin 

segment wider than the maximum recommended stitch length (10 

mm). Uncheck this box to disable the warning message.

9 When the “Show activation at start-up” box is checked, the 

Activation dialog will appear each time the program is opened. 

Uncheck this box to prevent the Activation dialog from opening.

Autosave is a function that periodically saves the open design or 
designs to disk, so that you will not lose all your edits in case of a 
service interruption. If you do have such an interruption, you will be able 
to restore the autosaved file by clicking the Restore Autosaved tool on 
the Accelerator menu.

You can always open the Activation Dialog by clicking on the Licence 
Activator button in the upper-right corner of the workspace.
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10 When the “Show Welcome dialog at startup” box is checked, the 

Welcome dialog will appear every time the program is opened. 

Uncheck this box to stop this dialog from opening.

11 Click OK.

The adjustments you have made will be implemented in the 
workspace.

Defining Grid Settings
The Grid Settings help you align and measure artwork and design 

elements. You can set the grid to measure in millimeters or inches 

according to your preference. You can display/hide the grid by 

checking/unchecking the box in the Display area of the Home tab.

By default, every 10th line will be highlighted in the major grid. If you 

want to have additional guide lines, you can add more major grid lines 

as well as a minor grid. You can increase or decrease the spacing of 

the minor grid; however, zero and negative spacing values are not 

supported. The minor grid can also have different horizontal and 

vertical spacing values.

To make grid lines more visible on particular backgrounds, you can 

change the color of the major and minor grids; separate colors may be 

chosen for the major and minor grids.

To define grid settings:

1 To open the grid settings dialog, do one of the following:

 Right-click on the rulers at the left or top of the window and 
click Grid Settings.

 On the View tab, click Preferences  and select the Grid tab.

You see the Grid settings dialog.

If you want, you can reset the environment settings to the original state 
by clicking the “Reset all preferences” button at the bottom of the 
Environment tab.
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2 In the Grid Minor area, complete the following:

 In the Horizontal spacing box, enter the measurements for 
horizontal spacing in millimeters or inches. 

 In the Vertical spacing box, enter the measurements for vertical 
spacing in millimeters or inches.

 From the Color list, select a predefined color to use for the 
minor grid. If you want to choose from a larger selection of 
colors, click Custom from the color box.

3 In the Grid Major area, complete the following:

 In the Horizontally Every (lines) box, enter how often you want 
horizontal lines to be highlighted in the major grid. For 
example, if you enter 3 in this box, every third horizontal line 
will be highlighted in the major grid.

 In the Vertically Every (lines) box, enter how often you want 
vertical lines to be highlighted in the major grid. For example, if 
you enter 5 in this box, every fifth vertical line will be 
highlighted in the major grid.

 From the Color list, select a predefined color to use for the 
major grid. If you want to choose from a larger selection of 
colors, click Custom from the color box.

4 In the Style area, select one of the following grid styles:

 Show grid as solid lines.

 Show grid as dashed lines.

 Show grid as dots.

5 Click OK.
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Auto Baste Settings
On the Auto Baste tab, the following settings can be adjusted: 

• An optional crosshair can be added in the baste to allow easier 
centering of designs on the fabric (this will be on by default).

• The stitch length can be adjusted to make a tighter or looser 
basting stitch (set to 6 mm by default). 

• The basting stitches segment may be offset from the actual design. 
You can adjust the “Baste past outer edge of design” slider to set 
this value, from 0-10 mm (set to 1 mm by default.)

If the stitch length or offset settings have been modified, and you want 

to reset them to the default values, click Use default.

For more information about using basting stitches, see Editing 

Designs–Adding Basting Stitches.

Color Sort Settings
The “Maximum allowable color overlap” allows you to adjust the 

sensitivity to the layering when the Color Sort tool is used. This setting 

determines what portion of the stitches must be overlapped, in order to 

allow a color change to be removed by the Color Sort tool. The overlap 

setting is expressed as a percentage; 0% means that no stitches will 

be overlaid in the process of performing the color sort, while 100% 

means the file will be compressed regardless of layering. The default 

is 5%, which seems to work very well for most designs.

Font Categorization
The BES Blue software includes many different fonts, in a wide variety 

of styles. The Font tab on the Preferences panel allows you to 

organize fonts into categories. You can organize the fonts into lists of 

different font styles, such as monogram or small lettering fonts; or, you 

may want to make a personalized list of the fonts you use most often, 

for ease of access.

To Create a new Font Category:

1 On the View tab, select the Preferences  button.

You see the Preferences dialog box.
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2 Click the Fonts tab.

You see the fonts preference page.

3 On the Fonts tab, click the New button.

You see the New category dialog.

4 Enter a name for the category, and click OK. 

The new name appears in the “Category” field. 
Below, the column to the left, the “Not included fonts,” shows the 
fonts that are available, and the column on the right, the “Included 
fonts” is currently unpopulated.
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5 Select one of more fonts from the “Not included fonts” list, and 

click the right-facing double-arrow  to add them to the 

“Included fonts” side.

6 Repeat the above step until you have added all the fonts that 

you want in this category.

7 Click OK to save this category with the selected fonts

The new font category will be saved, and will appear in the font 
category list when you select a font.

If you later want to remove a font that you added, select it and click the 

left-facing arrow  to return it to the “Not included” side.
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Using the Font Categories
To make use of the font categories, select a text segment, and look 
at the Text area of properties panel. In the Fonts properties area, 
click the down arrow to the right of the Font categories field, and 
select the desired category from the drop-down list. 

Now, the fonts listed in the Font field will be limited to those in the 

selected category. Apply the font as usual, by selecting and clicking 

Apply.

Note that the font category list includes some standard categories 
already, such as Applique Fonts and Run fonts; these are “system” 
categories that come pre-installed with the software, and cannot be 
edited or overwritten (i.e., you cannot create a font category and name 
it “Applique Fonts”).
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Adding a Backdrop Image
Use the Load Backdrop tool to import an image into the workspace. 

The loaded image can then be traced with Line tool. You can then use 

the Show Backdrop tool to view the design minus the backdrop image. 

Loading Backdrop Images
You can open an image file to use as a backdrop while creating 

designs. You can preview and open most standard raster and vector 

file types (e.g. *.WMF, *.BMP, *.JPG, *.AI, etc.).

To load an image as a backdrop:

1 On the View tab, click the on down-arrow under the select 

Backdrop  tool to open the fly-out menu.

2 On the fly-out, select the Load Backdrop  tool.

You see the Load Backdrop dialog.

3 In the Look in list, browse to the location of the image you want to 

load.

4 In the Files of type list, select a file type from the drop-down list.

5 In the File Name box, enter the file name for the image.

6 Click Open.

You see your backdrop image appear in the design workspace.

Showing and Hiding a Backdrop Image

You can use the Show Backdrop  tool to show and hide a loaded 

image. To access the Show Backdrop tool, click the down-arrow under 

the select Backdrop  tool to open the fly-out menu.

 When you load an image, it opens in its original size; however, you can 
resize, move, or rotate the backdrop image by clicking and dragging the 
handles on the selection frame.
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When you click this tool once, it hides the image without actually 

removing it from the design. Click the Show Backdrop tool a second 

time to restore the image.

Transforming Backdrop Images
Transforming a backdrop image is similar to transforming any object; 

however, to select the image, you will need to click on the Backdrop 

 tool.

BES Blue allows you to transform the image using backdrop menu 

options. This menu appears when you right-click on your backdrop 

image. You can use the menu options to show or hide your backdrop 

image, change your existing image, 4or edit your opened image.

You can also make adjustments to the Backdrop in the Properties box. 

In addition to the basic transformations (for example, scale and 

rotation). There is also a control on this tab that allows you to make the 

backdrop darker or lighter.

To adjust backdrop images in the workspace:

1 On the View tab, click the Backdrop  tool.

Your backdrop image will be selected.

2 Right-click the image and select any of the following menu options:

 Show Backdrop: This will allow you to turn the backdrop off.

 Define Horizon: Allows you to change the orientation of the 
backdrop image relative to the workspace. 

 Define Scale: Allows you to re-scale the backdrop image to a 
precise linear dimension.

 Load Backdrop: Opens the Load Backdrop dialog, allowing 
you to load a new backdrop.

You can also type Alt + S on the keyboard to show/hide the backdrop.
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To transform the backdrop from the Properties box:

1 On the View tab, click the Backdrop  tool.

Your backdrop image will be selected, and the Backdrop properties 
will appear in the Properties panel.

2 In the Width field, enter the width you want for the backdrop image.

3 In the Height field, enter the height you want for the backdrop 

image.

4 In the X and Y fields, enter the horizontal and vertical displace-

ments of the backdrop from the origin (0,0 point on the grid).

5 In the Scale box, enter the percentage value you want the design 

scaled to.

6 In the Rotate box, enter the number of degrees you want to rotate 

your design. To rotate the backdrop in 90-degree increments, 

select either the rotate left of rotate right buttons.

7 To lighten the backdrop image, enter a number into the 

Transparency field. Transparency is expressed as a percentage - 

the higher the percentage, the more transparent the backdrop will 

be.

8 Click Apply.

The backdrop image will be altered accordingly.

Adjusting the View of the 
Workspace

Magnifying and Reducing the View
Use Zoom to magnify or reduce parts of your design. With Zoom you 

can either left-click to enlarge your design or right-click to make your 

design smaller.

When you select Zoom, the cursor changes to a small magnifying 

glass . To use the Zoom tool, do one of the following: 

• To zoom in on the spot where the mouse is currently pointing, left-
click.

• To zoom out again, right-click.
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• To zoom in on a particular area, left-click and drag; the display will 
expand to show only the area that you have dragged over.

To use the Zoom Tool: 

1 On the Ribbon, select the Home tab.

2 On the Home tab, under Zoom, click the Zoom  tool.

The pointer becomes a magnifying glass.

3 Do either of the following:

 Left-click to make your design larger. 

 Right-click that area to make your design smaller.

To zoom-in on a specific area:

1 On the Ribbon, select the Home tab.

2 On the Home tab, under Zoom, click the Zoom  tool.

The pointer becomes a magnifying glass.

3 Click and hold your mouse button and drag it to form a flexible box 
around the area you want to see in detail.

4 Do one of the following steps:

 To increase the zoom, continue clicking and dragging the 
flexible box.

 Click on the down arrow under the Zoom icon, and use the 
Zoom tool settings to zoom back out.

Additional options on the Zoom Menu:
When you click on the down arrow underneath the Zoom Tool, you will 

see an option menu. You can choose from any of the following options 

on this menu:

• Zoom In to make your design larger.

• Zoom Out to make your design smaller.

• To Fit to make the whole design the size of the design window.

• To Selection to zoom to the size of the currently selected 
embroidery segment, or set of embroidery segments if more than 
one is selected.

• 1:1 to see the design at the actual size.
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Hiding the Sequence and Properties 
Panels Automatically
To increase the amount of space for your design window, you can set 

the Sequence and Properties panels to the Auto hide mode. When 

Auto hide is on, the panel will only be visible while the mouse is over it; 

as soon as you remove the mouse, the panel will collapse to become a 

small tab at the edge of the design workspace.

To turn on Auto hide for these panels, click on the small push-pin icon 

 at the top-right of the panel. 

To show the panel again, hover the mouse over the tab to show it; 

then, click the push-pin  icon to turn Auto hide off.

Viewing Different Parts of the 
Workspace (Panning)
Sometimes you may want to work at a high level of magnification, and 

some part of the garment or embroidery you’re working on will not 

show up in the workspace.You can move to parts of your design that 

go beyond the window’s borders. In these situations, you can use 

keyboard arrows or the pan tool to change your view of the project.

Panning using the keyboard:

• Use the ↑ key to move up.

• Use the ↓ key to move down.

• Use the ← key to move left.

• Use the → key to move right.



44 BES Blue
Using the Pan Tool

Use the Pan  tool to move the view of the design around in the 

workspace by clicking and dragging. While you are using the Pan tool, 

you will still be able to see the design in the window. The pan tool does 

not actually move parts of the design around, just your view of them.

Taking Measurements

The Ruler  tool lets you measure the distance between any two 

points in your design workspace. When you measure from one point to 

another, the distance is displayed in the status line located at the 

bottom of the window. The status line shows the total length 

measured, the length in the horizontal (width) and vertical (height) 

directions, the angle of the line (compared to horizontal).

To measure Designs:

1 On the Ribbon, select the Home tab.

2 Click on the Ruler  tool.

Your pointer changes to a ruler when in the Design Workspace.

3 Click and drag your mouse until you are finished measuring the 

item. 

4 Let go of your mouse when you are finished measuring. 

The measurement is now displayed in the status bar.

You can right-click to switch back to whichever tool you were using 
before you selected the Pan tool.

The ruler measurements are calculated in the units you set under the 
Units tab of the Preferences dialog.
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Displaying the Hoop
Viewing the hoop or frame on the screen lets you ensure that your 

design fits properly when you run it on the machine. The hoop serves 

as a guide to help size and position your design in the design window. 

BES Blue comes with many pre-loaded hoop sizes.

Viewing and Hiding the Hoop

Use the Hoop  tool to show and hide the hoop in the display 

window. Just click on the Hoop tool to show the hoop (if it is not 

currently shown) and click it again to hide the hoop.

Selecting a Hoop
You can select one of the pre-loaded hoops using the Hoops dialog. 

You will notice that you can select hoops from different file types in this 

dialog. This is useful when you want to make sure that your design will 

fit for more than one kind of embroidery machine.

If you want the design to maintain the same position in the current hoop 
when it is saved, closed, and then re-opened, ensure that the “Maintain 
Hoop Placement on load” is checked in the Preferences dialog—
Formats tab. Otherwise, the design will be centered in the hoop upon 
loading.

The hoop’s dimensions are set using the “Select Hoop” option   under 
the Show/Hide Hoop button. See the following section, “Selecting the 
Hoop.”

Displaying the Hoop may effect the magnification level of your design. 
For example, if you are zoomed in on the design, displaying the Hoop 
will cause the view to zoom out enough to fit the entire hoop into the 
workspace.

To set the location of the hoop bracket, so that it corresponds to the 
location of the bracket on your machine, go to the Preferences dialog–
Formats tab, and chose the correct location from the list; the position of 
the hoop bracket in the workspace will change accordingly.

See “Format Properties”, page 29.
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To select a hoop using the Hoops dialog:

1 On the Home Tab click the down arrow under the Hoop tool.

2 From the menu that appears, click on Select Hoop. 

You see the Hoops dialog.

3 Select the machine format from the Format drop-down list.

4 From the list of Hoops, choose a hoop size appropriate for your 

design.

5 If needed, check the “Rotate 90” box to make the hoop fit your 

design better.

6 Click OK.

If you choose the PES format, you will see that there is an option to 
select “MultiNeedle” hoops. This applies only if you have a MultiNeedle 
embroidery machine.

If you check this box, the list of hoop formats will change to a list of 
hoops that are used with a MultiNeedle machine.
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Creating a Custom Hoop
You can also create your own custom-sized hoops using the Hoops 

dialog. Once you have set the parameters for your hoop and typed in a 

description, the custom hoop will be saved by the Hoops dialog; it will 

be available for your use in future designs.

To add a custom hoop:

1 On the Home Tab click the down arrow under the Hoop tool.

2 From the menu that appears, click on Select Hoop. 

You see the Hoops dialog.

3 Click the New button.

You see the New Hoop dialog.

4 Enter the dimensions for your new hoop in the Width and Height 

boxes.

5 In the Name box, type a name for your custom hoop.

6 Click OK.

The new hoop’s name will now be displayed in the list of hoops that 
you can select from in the Hoops dialog.

7 Click on the name; the new hoop’s dimensions now appear in the 

Hoops dialog on the lower right of the dialog.

8  Click Apply.

The new hoop shows in your design location.
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Getting Help
The BES Blue Help is a quick way to find answers to your questions 

and see step-by-step instructions. The Help allows you to search for 

topics in various ways. You can search using the table of contents, the 

index or a database of keywords. You can also save the topics you 

visit most often.

Opening the Help

To open the Help:

1 Double-click the BES Blue icon on your desktop.

You see the blank design workspace.

2  Click the Help  tool in the upper right corner of the tab bar.

You see the Help. 

Using the Contents
The Help has a table of contents, with a list of book icons. Each book 

contains a series of related topics. 

To use the Contents: 

1 Click the Help  tool in the upper right corner of the tab bar.

You see the Help. 

2 Double-click the book you want to open. 

3 Click the topic you want to see.

You see the topic in the right pane.

The help is also available in document form (PDF).To view or print the 
instruction manual as a PDF, insert your Installation USB and select 
View Instruction Manual from the options.
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Using the Index 
The Help index is similar to the index in a book. 

To use the Index:

1 Click the Help  tool in the upper right corner of the tab bar.

2 In the box, enter the word or words you want to search for.

In the list, you see the topics that most closely match your query. 

3 Click the term you want to learn more about.

If there is more than one topic for the keyword, you see a menu. 

4 Click the topic you want to see. 

You see the topic in the right window pane.

Using Search
The Search tab lets you search using keywords or phrases in a 

database of all the words found in the BES Blue Help. 

To use Search:

1 Click the Help  tool in the upper right corner of the tab bar.

2 Select the Search tab. 

3 In the “Keyword” box, enter the word or phrase that you are 

searching for.

4 Click the List Topics button.

In the list below, you see the topics that contain the words you 
searched for. 

5 Click the topic you want to view, and then click Display. 

You see the topic in the right window pane.

Saving Favorite Help Topics
The Favorites tab lets you save the topics that you visit most often and 

want to access quickly.

To save your favorite topics:

1 Click the Help  tool in the upper right corner of the tab bar.

2 Double-click the book you want to open. 
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3 Click the topic you want to save as your favorite.

You see the topic in the right window pane.

4 Click the Favorites tab.

You see the selected topic in the Current topic area.

5 To add the selected topic to your favorites list, click Add.

You see the selected topic appear in the Topics area.

6 To display your favorite topic, do one of the following:

 In the Topics area, select the favorite topic you want to display 
and click Display.

 In the Topics area, double-click the favorite topic you want to 
display.

You see the topic in the right window pane.

7 To remove one of your favorite topics, do the following:

 In the Topics area, select the favorite topic you want to remove 
and click Remove.

Printing Help topics
You can print any of the topics in the Help. 

To print topics:

1 Click the Help  tool in the upper right corner of the tab bar.

2 Click the topic you want to print.

The topic will appear in the Help window.

3 Click Print.

You see the Print Topics dialog box. 

4 Select one of the following print options:

 Print the selected topic

 Print the selected heading and all subtopics

5 Click OK.

You see the Print dialog box.

6 Change any of the print settings, if necessary, and click OK.

The topic will be sent to your printer.



You can add beautiful lettering to your designs using various BES Blue 

tools. Generate unique embroidery text in an array of shapes and 

sizes using our powerful Text tools.

Topics covered in this chapter:

• Creating lettering with the text tools: Normal, Path, Follow Path, 

Vertical, Circle, Step and Spiral.

• Using the Monogram Text tool to create monogram lettering.

• How to modify blocks of text, and individual letters within text 

segments.

• Adjusting the spacing between individual letters.

CHAPTER 2:

Creating Lettering
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Using the Text Tools
There are seven different tools which are used to input your lettering 

into a design: the Normal Text tool, the Path Text tool, the Vertical Text 

tool, the Circle Text tool, the Monogram tool, Step Text tool, and Spiral 

Text tool. The following sections describe how to use these tools.

Normal Text Tool

Normal Text items are created using the Normal Text  tool. Normal 

text items start out with normal proportions for the font, and can be 

adjusted.

To create Normal Text:

1 On the Ribbon, select the Home tab.

2 On the Text bar, click on the Normal Text  tool.

3 Click once in the design window.

An empty text frame appears in the workspace, and the mouse 
pointer changes to an arrow with the letter A next to it .

4 Type the desired text string. To create a multi-line text segment, 

press ENTER, which will drop the cursor down one line, and 

continue to enter your text.

5 Right-click to complete the text segment.

Your text appears in the design. You can now make any other 
changes to the text segment in the Text Properties box.

6 To choose a new font (i.e., other than the currently selected one) 

for the text string at this point, do the following:

 In the Text area of Properties Panel, click in the Font field to 
select it.

 Click on the down-arrow to the right of the font field.

You see a list of fonts.

 Select the desired font from the list.

If another text item was already selected, your first click only de-
selected that item. You will have to click again to place a new text 
segment.
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A preview of the newly selected font is now displayed at the top 
of the properties panel.

 Click Apply in the Properties Panel.

For information on changing other text settings, see “Normal Text 
Properties”.

Path Text Tool

The Path Text  tool creates lettering that follows a set linear path. 

For example, you can use the Path tool to create text that bends to 

follow the curved edge of a garment.

BES Blue comes with a set of shapes already installed for you to 

choose from, or you can create and save your own shape, using the 

Edit Shape command. 

See “Creating a Custom Text on a Path Shape”.

To create text along a path:

1 On the Home tab, click the Path Text  tool.

2 Click once in the design window.

You see the Select a text path dialog.

If another text object was already selected, your first click only 
de-selected that object. You will have to click again.
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3 Select one of the paths from the Select a text path dialog.

The Select a text path box closes, and you see a blank text frame of 
the chosen shape in the design window.

4 Select a font for your text by doing the following:

 In the Text area of Properties Panel, click the down-arrow to the 
right of the font field.

You see a list of fonts.

 Select the desired font from the list.

A preview of the newly selected font is now displayed at the top 
of the properties panel.

 Click Apply in the Properties Panel.

5 Type in the text.

6 Right-click to complete the text segment.

Your text appears in the design. You can now adjust its properties in 
the Text Properties box; for more information on changing text 
settings, see “Text Properties”.

7 Click Apply.

Your text will change accordingly.

Important: If you choose a new font, but do not click Apply at this 
stage, the text will revert to the font previously in use when it is 
generated.



Creating Lettering 55
Follow Path Text Tool

Text segments made with the Follow Path  tool, like text made with 

the Path Text tool, follow a pre-determined line shape (path) which is 

selected from a dialog. However, in a Follow Path text segment, the 

letters are distributed evenly along the path, rather than being aligned 

to the beginning, middle, or end, as in the Path Text segment. 

To create text along a path:

1 On the Home tab, click the Follow Path  tool.

2 Click once in the design window.

You see the Select a text path dialog.

3 Select one of the paths from the Select a text path dialog.

The Select a text path box closes, and you see a blank text frame of 
the chosen shape in the design window.

4 Select a font for your text by doing the following:

If another text object was already selected, your first click only de-
selected that object. You will have to click again.
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 In the Text area of Properties Panel, click the down-arrow to the 
right of the font field.

You see a list of fonts.

 Select the desired font from the list.

A preview of the newly selected font is now displayed at the top 
of the properties panel.

 Click Apply in the Properties Panel.

5 Type in the text.

6 Right-click to complete the text segment.

Creating Custom Path Shapes
In addition to the existing Path Text shapes, you can create and save 

your own shape, using the Edit baseline command. You are also able 

to change the characteristics of the anchor points when in Edit 

baseline mode; you can convert the anchor point to Line, Cusp, 

Smooth, or Symmetrical. 

For more information, see “Changing the Anchor Point Type.”

To create a custom path:

1 Select the Path Text tool and use it to create a text segment.

Important: If you choose a new font, but do not click Apply at this 
stage, the text will revert to the font previously in use when it is 
generated.
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2 With the Path Text still selected, right-click and choose Edit 

baseline from the options menu.

The baseline shape appears along the bottom of the text, showing 
the anchor points (blue squares).

3 To add new anchor points to a Path Text baseline, do the following:

 Right-click on the line.

 From the context menu that appears, select Add Point.

A new anchor point is added to your baseline. 

4 Click and drag the anchor points and direction lines to modify the 

shape of the baseline.

5 Right-click to redraw the lettering so that it follows the new curve. 

6 To save your custom shape, right-click and choose “Export Text 

Path” from the options.

You see a Save as dialog.

7 Type in a name for the new Text Path and click save. 

The new Text Path will now appear in the Select paths dialog when 
you use the Text on a Path tool.

Changing the Anchor Point Type

When you are editing the baseline of a Path Text segment, you can 

select anchor points and change their type. An anchor point can be a 

line, cusp, smooth or symmetrical point. The different types change 

the way that the baseline curves.

To change an anchor point to line, cusp, smooth or 
symmetrical:

1 Select a Path Text segment.

2 Right-click and choose Edit baseline from the options menu.
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3 Hover over the anchor point you want to change (a blue dot will 

appear next to the mouse pointer) and right-click.

You see a shortcut menu.

4 Choose one of the following types of anchor points available:

 Line: Removes the direction lines from the anchor point. 
Creates a straight point without any curved properties.

 Cusp: Allows editing of the direction line on one side of the 
anchor point. Adds a sharp bend to a curve.

 Smooth: Constrains the angle of the direction lines to 180º and 
allows you to vary the length of the direction line on one side of 
the anchor point. Creates a smooth transition between curved 
lines.

 Symmetrical: Constrains the angle of the direction lines to 
180º so the direction lines have the same length on each side 
of the anchor point. Creates some curvature on both sides of 
the anchor point.

Vertical Text Tool

Vertical Text items are created using the Vertical  tool. Vertical text 

items are those that are created vertically. They start out with normal 

proportions for the font, and can be adjusted.

To create vertical text:

1 On the Ribbon, select the Home tab.
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2 On the Text bar, click on the Vertical Text  tool.

3 Click once in the design window.

An empty vertical text frame appears in the workspace.

4 To choose a new font (i.e., other than the currently selected one) 

for the text string at this point, do the following:

 In the Text area of Properties Panel, click the down-arrow to the 
right of the font field.

You see a list of fonts.

 Select the desired font from the list.

A preview of the newly selected font is now displayed at the top 
of the properties panel.

 Click Apply in the Properties Panel.

5 Type the desired text string.

6 Right-click to complete the text segment.

Your text appears in the design. You can now make any other 
changes to the text segment in the Text Properties box.

Circle Text Tool

Text on a circular path is created using the Circle Text  tool. When 

the text is first created, it is given a default font height and circle 

diameter, which can be adjusted using the text tools.

To create Circle Text:

1 On the Ribbon, select the Home tab.

2 On the Text bar, click the Circle Text  tool.

If another text item was already selected, your first click only de-
selected that item. You will have to click again to place a new text 
segment.

Important: If you choose a new font, but do not click Apply at this 
stage, the text will revert to the font previously in use when it is 
generated.
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3 Click once in the design window.

An empty Circle Frame appears in the workspace.

4 Type the desired text into the “Upper Text” and “Lower Text” fields 

in the Properties Panel.

5 Right-click to complete the text segment.

Your text appears in the design. You can now make any other 
changes to the text segment in the Text Properties box.

6 To choose a new font (i.e., other than the currently selected one) 

for the text string at this point, do the following:

 In the Text area of Properties Panel, click in the Font field to 
select it.

 Click the down-arrow to the right of the font field.

You see a list of fonts.

 Select the desired font from the list.

A preview of the newly selected font is now displayed at the top 
of the properties panel.

 Click Apply in the Properties Panel.

Creating Monograms

Monogram Text items are created with the Monogram Text  tool. 

When you create a Monogram text item, it is three letters long by 

default (but this can be changed on the properties panel). Decorations 

can be added to Monogram items for those fonts that support them.

To create standard Monogram text:

1 On the Ribbon, select the Home tab.

If another text item was already selected, your first click only de-
selected that item. You will have to click again to place a new text 
segment.

Text typed in the Upper Text field will by centered at the top of the 
circle, and will run clockwise, while text typed in the Lower Text field will 
be centered at the bottom, and run counter-clockwise. 
For more information, see “Changing Text Direction” in the “Text 
Properties” section of the manual.
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2 On the Text bar, click on the Monogram  frame tool.

3 Click once in the design window.

A monogram text frame appears in the workspace, and the mouse 
pointer changes to an arrow with the letter A next to it .

4 Type the three letters of your monogram into the frame.

5 In the Monogram area of the Properties Panel, select the font you 

wish to use in the in the Font field.

6 Click the Apply button at the bottom of the properties panel.

You can also make any other changes to the settings in the 
Properties box.

Hint: Using Text Connectors to create a ‘Custom’ 
Monogram

BES Blue features an additional way to make monograms, using a set 

of Text Connector designs included with the Add design tool. When 

used in conjunction with Normal text, Text Connectors can be used to 

make custom monograms. To do this, use the Text tool to place two 

letters (separate segments work best for this) in the design. 

If another text item was already selected, your first click only de-
selected that item. You will have to click again to place a new text 
segment.
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Then, on the Home tab, select Add Design tool. In the Add Design 

dialog, select Connectors from drop-down list, choose the desired text 

connector from the selection box, and click in the design to place the 

connector. 

For more information on how to use the Add Design tool, see “Special 

Design Tools—Add Design Tool.”

Step Text tool

Step Text items are created using the Step Text  tool. In a Step 

Text text item the letters are arranged so that they go down an angled 

path, as if they were on a staircase. By default, the Step Text path will 

descend at a 45-degree angle, but this angle can be adjusted in the 

properties panel. 

To create Step Text:

1 On the Home tab, select the Step Text  tool.

2 Click once in the design window.

An empty Step text frame appears in the workspace.

3 Enter the desired text into the frame.

If another text item was already selected, the first click only de-
selected that item; you’ll have to click again.
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4 Right-click to complete the text segment.

Your text appears in the design.

5 You can adjust the angle by entering a different angle in the Line 

angle field Properties box. (By default, the Step Text item will 

descend at a 45º angle.) 

6 Make any other changes in the Step Text properties box.

7 Click Apply.

Your text will change accordingly.

Spiral Text tool

The Spiral Text  tool creates a text segment in a spiral shape. As 

with other text types, the text and properties of the spiral segment can 

be adjusted in the properties panel.

To create spiral text:

1 On the Ribbon, select the Home tab.

2 In the Text bar, click the Spiral Text  tool.

To make a text segment that ascends, rather than descends, enter 
a negative sign in front of the value in the Line angle field (0º will 
make a horizontal line).
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3 Click once in the design window.

An empty Spiral Text frame appears in the workspace.

4 Enter the desired text into the frame.

5 Right-click to complete the text segment.

Your text appears in the design.

You can now make any other changes to the segment (choose font, 
set letter height, etc.) in the Properties Panel.

If another text item was already selected, your first click only de-
selected that item. You will have to click again to place a new text 
segment.
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Text Frames – an Overview
In BES Blue, you can modify your lettering in a number of different 

ways once you have created it. You can change the overall size of the 

text, the height, the slant, the spacing between letters (kerning), and 

so on.

There are two main methods of changing the size and shape of a text 

segment: directly, by clicking and dragging on the outline handles in 

the workspace, or indirectly, by changing the parameters in the Text 

section of the Properties Panel. The following sections will show you 

how to use handles for direct text manipulation; for more information 

about how to use the properties panel, see, “Adjusting Text 

Properties”.

Adjusting Size of a Text Segment
To change the size of a text segment manually, you can use the 

Proportional Sizing handle. This is the green arrow located on the top-

left corner of the text frame. 

Click and drag on the Proportional Sizing Handle to change the overall 

size of the text; up to increase the size, down to decrease the size. 

Note that the size of the text changes proportionally; that is, if you 

increase the size of the segment, the letters will increase in height by 

the same degree that they increase in width.

Note that not all of the ways of adjusting the text will apply to all types 
of text frames; for example, the Envelope function and the Envelope 
handles apply to the Normal Text and Monogram frames only. 
Where applicable, the section will list the frame types to which these 
handle can apply; if not stated, you can assume that the handle is 
present for all frame types.



66 BES Blue
Adjusting the Width of Text
If you want to change the width of the text of segment, without 

changing the height, use the frame’s Width Handle.

The Width Handle is the green arrow at the bottom-right of the text 

frame. Click and drag to the right to increase the width, and to the left 

to decrease the width. 

Adjusting the Corners of Text Segments
Use the Corner Handles to change the shape of a text segment. The 

Corner Handles are at each corner of the text frame, and are pink in 

color.

 

When you click and drag these handles up or down, they change to 

position of the selected corner of the text frame; when you release the 

mouse button, the embroidery is regenerated to match the change in 

shape. This gives you the ability to create text that slopes up or down.

If you want to adjust the height of a design, it can be done in the 
Height box in the Text tab. Enter the new size and click Apply.

These handles are applicable only to Normal Text frames and 
Monogram Text frames.
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Using the Envelope Handles
These handles apply only to Normal Text and Monogram text items. 

These two types of text are surrounded by a flexible bounding box, 

called an envelope. You can adjust this shape by moving the Envelope 

Handles.

The Envelope Handles are the pink circles, located at the mid-point of 

the top and bottom borders of the text frame. Click and drag these 

handles to make the top and/or bottom of the frame concave (“bowed 

in”) or convex (“bowed out”)

Rotating Text
Use the Rotation handle to change the angle of a text segment. This is 

the orange circle at the top-left corner of the text frame.

To rotate a segment, first position the mouse over this handle so that 

the cursor changes to a circle-arrow handle . Then, drag the 

handle to rotate the segment to the desired angle. Drag up to rotate 

counter-clockwise, and down to rotate clockwise. Notice that, as you 

rotate, the tool displays an outline preview of the lettering, showing 

how far you are rotating it. Release the mouse button to “drop” the 

segment, and generate the stitches at the new angle.

You can also apply an envelope shape to a text segment through the 
Properties Panel. You can use the Envelope property in the Text area 
to apply a predefined envelope to a Normal Text or Monogram text 
item.

For Circle Frames, note that the rotation handle appears on the inner 
circle of the frame, centered under the top text string.
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Dragging this handle rotates the design to any angle. You will see an 

outline of the design rotate onscreen as you are dragging, and the text 

will be regenerated when you release the mouse.

Adjusting the Slant of Text
The angle of the letters in a text object can be adjusted with the Slant 

Handle. The Slant Handle is the square blue handle located to the 

lower-left of the selection box.

To adjust the slant of text, select the text object you want to adjust, 

click the Slant Handle and drag. To add a forward (positive) slant to 

the letters, drag to the right and to add a backward (negative) slant, 

drag to the left.

Resetting the Frame
The Reset Frame function allows you to undo any of the frame 

adjustments described above (e.g. rotating, changing the envelope, 

etc.) and restore it to the original state. All frame adjustments will be 

undone.
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To reset a text frame:

1 Select one of the text tools.

2 Select the text frame, and right-click.

You see a context menu.

3 Click Reset Frame.

The text will be return to the original state.

Adjusting the Size of Text in the Circle 
Frame
The size of text items can be adjusted using the Proportional Sizing 

Handle. This handle is at the top of the lettering and appears as a blue 

circle.

Select the Circle Text tool and place your mouse pointer over this 

handle; you will see that it changes to a small cross.
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As you drag this handle, you will see the design scale proportionally, 

which means that as you make the text taller, it also gets wider.

Adjusting Text Width in the Circle Frame
You can adjust the overall spacing between letters in Circle Text with 

the width handle; this is the blue circle at the lower-right side of your 

text. 

To adjust the width, select the Circle Text tool, and click on the text to 

select it. When you place your pointer in the width handle, you will see 

that it changes to a small cross. By dragging this handle, you will be 

able to adjust the width of the text segment. 

Note that the spacing between the lettering changes proportionally as 
you increase and decrease the size of the segment. To adjust the 
spacing between letters individually, see “Working with individual 
letters–Adjusting the spacing between letters (kerning).”
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To change the height and width at the same time, see “Adjusting the 

size of text in the Circle Frame”

Changing the Diameter of the Circle 
Frame
You can change the overall diameter of the baseline of your Circle Text 

using the Rotation Handle. This is the orange circle on the inner edge 

of the Circle Text frame. Place your mouse over this handle and the 

pointer will change to a circle-arrow handle . Then, drag in or out 

along a radius to increase or decrease the diameter of your Circle Text 

segment.

Working with Individual Letters
The text tools allow you to make changes to individual letters within 

the text segments in your designs.

You are able to select a letter, and move it, rotate it, and resize it by 

using the handles that surround the letter when it is selected. You can 

also change the spacing of letters within the word with the special 

kerning handles.

If, after performing any of the adjustments above, you wish to return the 
frame to its original size and shape, right-click on the workspace and 
choose Reset Frame from the option menu. The frame will reset itself.
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Adjusting the Space between Letters 
(Kerning)
The space between individual letters can be adjusted using the 

Kerning Handles.

Kerning Handles are blue diamonds, located between the letters of 

your text segment. You can drag these horizontally to adjust the 

spacing of the text.

Moving Individual Letters
Individual letters can be moved using the Letter Handles. These 

appear as blue squares, centered on each letter in the segment.

To select a letter, click on its Letter Handle; once the individual letter is 

selected, you can adjust its position by dragging with the mouse.

Selecting a letter also activates the Letter Frame around that letter. 

This frame displays handles that allow you to resize or rotate it; see 

following sections.

When you move a kerning handle in a word, you adjust the space 
between only the two letters on either side of the handle you are 
moving; the spacing between the other letters remains the same. 
So, if you add space, you will see the whole length of text expand 
by this amount.
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Resizing Individual Letters
When an individual letter has been selected, you can resize it by 

clicking and dragging the Letter Size Handles. The Letter Size 

Handles are green squares that are located in the corners of the letter 

frame.

When you hover over these handles, a double-ended arrow appears; 

by dragging up or down on this handle, you increase or decrease the 

size.

Rotating Individual Letters
When you select an individual letter with its Letter Handle, you can 

rotate it by clicking and dragging the Letter Rotation Handles. The 

Letter Rotation Handles are the green circles at the corners of the 

Letter Frame. When you hover over these handles, the mouse pointer 

will become a circle with arrows, like this.

Drag up to rotate counter-clockwise, and down to rotate clockwise. As 

you rotate, the tool displays an outline preview of the letter, showing 

how far you are rotating it.

When the cursor is placed over the text function handles, the 
cursor changes for the different functions.
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Using Alpha Mapping to Create a 
Custom Font
The Alpha Mapping feature allows you to create a new, personalized 

font, based on existing stitch or outline (*.BRF) alphabet files. You 

build the font by assigning these designs to each of the letters in the 

alphabet (upper- and lower-case), plus punctuation marks. There are 

also a number of special Spanish-language characters available to be 

used, such as, á, é, ñ, ¿ etc.

You assign letters to the new font by dragging and dropping the design 

files onto the Font Mapping table of the Alpha Mapping dialog.

Each square of the Font Mapping table corresponds to a single 

keystroke on your keyboard - i.e., whatever you put in the “A” box on 

the Font Mapping table is what will appear (for that font) when you 

type a capital “A”, and so on for all the other available keystrokes.

Once you have created and saved a font using the Alpha Mapping 

tool, you will see the new font on the list of fonts in the Text Input 

dialog, and also in the list of fonts on the Text tab of the Properties 

Panel.

Note that each letter that you import to build the new font must 
come from a separate design file.

Any font that is created with the Alpha Mapping will have a 

small icon to the right of the font name, like this: .
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Mapping a New Font

To use the Alpha Mapping:

1 On the Home tab click the Alpha Mapping  tool.

You see the Alpha Mapping dialog.

2 Click the New Font button.

A new dialog pops-up in front of the Alpha Mapping dialog.

3 Type a name for the font into the New Font dialog, and click OK.

4 Type in your name in the Author field of the dialog (this step is 

optional).

5 Adjust any of the following parameters for the mapped font:

 Spacing: Sets the letter spacing (in points) within words.

 Word Spacing: Sets the spacing (in points) between words.

 Height: To override the font height calculated according to the 
reference letter, check Custom Height and enter the override 
letter height value in the Height field.

6 On the right side of the dialog, select the browse  button to 

navigate to the Design folder containing the embroidery files that 

you want to use to create the font.

You see thumbnails of the folder’s contents in the preview window 
on the right side of the dialog.

For more details on the Spacing, Word Spacing, and Custom Height 
font settings, see “Options for the Alpha Mapping Tool,” below.
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7 Set the reference letter: Click and drag the design that you want to 

use as the reference letter for the font (normally, the capital “M” 

would be used) into the corresponding square in the Font Mapping 

table.

When you are mapping a font, you can import the files from any number 
of different locations on your computer. When you have finished 
importing the files you want from one folder, simply click the browse 

 button again to navigate to a new directory.

Important: The first letter that you add to a new font is treated as the 
“Reference Letter”. This means that the extents of this letter - that is, 
the maximum width, and maximum height - will be used as the basis 
for the entire font.
This size effects the spacing between letters, as well as the spacing 
between lines in multi-line lettering segments. Also, the height of the 
reference letter determines the default height of this font. This is the 
height measurement that appears for this font in the Text input dialog.

Since a capital “M” is usually the largest letter in any font, it is normal to 
choose M as the reference letter.
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8 To map the remaining letters of the new font, select a range of 

designs and do one of the following:

 Click the A-Z button to map the designs to the upper-case 
letters (A, B, C...).

 Click the a-z button to map the designs to lower-case letters (a, 
b, c...).

 Click the Aa-Zz button to map the designs to upper- and lower-
case letters alternately time (A, a, B, b, C, c...).

 Select 0-9 to map the designs to the numerals (1, 2, 3...).

 Click the Auto button to map all letters and numbers 
automatically.

The mapped letters appear in the Font Mapping window.

Important Note: When using the “Auto” method for mapping letters, 
the name of the stitch file must correspond to the letter that you are 
mapping it to. For example, if you want to map a *.brf file to the upper-
case letter “A” in your new font, that file must be named “A.brf”

If some (or all) of the files you select for Auto mapping have names that 
do not correspond to the letter they are being mapped to, the Alpha 
Mapping wizard will display an error message.

As an alternative method, you can map the embroidery files into the 
font by dragging and dropping them individually into the spaces in the 
Font Mapping table.
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9 Click Save to save the font, and Close to close the dialog and 

return to the main Letter It workspace.

The new font will now appear on the list of fonts in any of the text 
tools, and also in the font list in the view.
Note that the any of the fonts created with the Alpha Mapping have 
a small C in front of the of the font name, like this: .

Options for the Alpha Mapping tool

Base-line adjustment

By default, the designs you import into the new font will be placed right 

on the base line of the lettering segment. (You can see this base line 

as the blue dashed line in the individual letter’s frame in Alpha 

Mapping).

If you want to remove one of the letters in the font, you can click the 
small red “X” in the corner of the letter frame; or, you can change the 
letter assigned to that keystroke by simply dragging a new file onto it.
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For some letters, however, this will not be the position that you want 

them to be in when they are used in a text segment. For example, 

letters like “y” or “j” might end up with the “tail” right on the baseline, 

rather than below it.

To rectify this problem, there is a baseline adjustment amount, which is 

shown in the lower-left corner of each letter frame when that letter is 

selected for editing. In the default state (that is, with no base-line 

adjustment) this area will read 0.0. There are three ways to adjust the 

baseline for the letter:

• Click the letter in the frame, and drag it up or down.
• Click on the up or down arrows on the right of the baseline 

adjustment indicator to move the letter up or down; as you do, the 
letter is adjusted (up or down) by 0.1 mm per click.

• Click in the baseline adjustment indicator field to select it, and then 
type a number into it directly. Press Enter to input the change.

Spacing

If desired, you can increase the spacing by typing a value into the 

Spacing box on the dialog. Spacing is calculated proportionally, in 

terms of the reference letter of the font. The spacing is expressed in 

“points”, where 20 points is the width of the reference letter. 

For example, if you were to enter a spacing value of 10, then the 

spacing between letters when you typed out some text would be half 

the width of the reference letter.

As you change the position of the letter, you see the preview 
image move relative to the dashed blue line in the letter’s frame.
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Word Spacing

The Word Spacing setting assigns a width to the “space” character of 

the mapped font, expressed in “points,” where 20 points = the width of 

the reference letter. This value is set at five points by default, but you 

can make it larger or smaller, to increase or decrease the spacing 

between words created in this font. 

Height

Normally, when you create a new font using the Alpha Mapping tool, 
the height is fixed to a certain absolute value - determined by the 
original height of your reference letter. Subsequently, this height will 
appear as the default height for the font in the Text Input dialog, but 
will be “grayed out” - i.e., it cannot be adjusted. 

This is because often, the files used to create letters in the Alpha 

Mapping are stitch files (e.g. *.PES, *.SEW, *.JEF, etc.). These files do 

not resize well, since new stitches are not generated when they are 

scaled up or down, so it is highly recommended that fonts created with 

these files not be resized.

However, if you do want to be able to change the height of the new 
font, it is possible to override the fixed height. To do this, check the 
“Custom Height” box in the dialog; this will allow you to change the 
font’s height in the Properties Panel when you use it, like any other 
font. See “Changing the Size of Text” in the “Creating and Adjusting 
Lettering” section of this manual.

When *.BRF files are used to build a new font, the situation is different; 

these files include vector outlines, and so the stitches are recalculated 

when the letter’s size is changed. Therefore, if *.BRF files are used to 

build your new font, it can be resized safely.

Resizing stitch files more than a few percent larger or smaller can yield 
poor results when sewn out.

Note that the Custom Height is given in millimeters.
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Editing the Mapped Font
You can also use the Alpha Mapping dialog to make changes to your 

imported font, after you have created it. You can re-open a font, add or 

delete letters within it, or change the spacing or height of the font (if 

applicable - see “Custom Height”).

You can also use the Alpha Mapping dialog to delete or rename your 
imported fonts. 

To make changes to an existing custom font:

1 On the Home tab of the ribbon, click the Alpha Mapping  tool.

You see the Alpha Mapping dialog.

2 In the Font list, in the upper-left corner of the dialog, click the 

down-arrow to display the list of fonts.

3 Click on the font’s name so that it is highlighted.

The font will be loaded into the Font Mapping table. You may now 
make changes to the letters, the spacing, and so on.

4 When done making changes, click the Save button.

The changes you have made will appear in the selected font.

To edit your font list:

1 On the Home tab, click the Alpha Mapping  tool.

You see the Alpha Mapping dialog.

2 On the Alpha Mapping dialog, click the Edit Fonts button.

The Edit Font dialog appears, displaying a list of all the Imported 
fonts in your copy of BES Blue.

3 Do either of the following: 

 To delete a font, select the name and click the Remove button.

 To rename a font:

 Select the font and click the Rename button.

 Type the new name overtop of the old one.

In case you change your mind, and DO NOT want to have these edits 
applied to the font, click the Close button instead of the Save button. 
A warning dialog will then appear, asking if you want to proceed 
without saving the changes, click Yes. This will close the Alpha 
Mapping dialog without implementing the changes.
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4 In the Edit font dialog, click the Close button.

The changes you have made will now be reflected in the list of fonts 
in the lettering tools and in the Properties Panel.

Working with Color in Text 
With BES Blue, you are able to choose a text item’s color from a large 

variety of thread colors. You apply the color by selecting from the 

colors available in your currently loaded thread palette. For more 

information on how to use the thread palette, see “Working with the 

Color Palette.”

Changing the Color of a Text Segment
The following procedure applies to situations where you want to simply 

change the thread color of an existing text segment to a new color.

To change the thread color of a Text item:

1 Do one of the following.

 Select the text item in the workspace, using either the Select 
tool or one of the text tools.

 Click on the text item in the Sequence view.

2 In the Color Palette, click the color box with the thread color you 

want to use.

Changing the Color of Letters in a Text 
Segment
If an individual letter has been selected, its color can easily be 

changed. Selecting the letter allows you to select a new color from the 

color palette.

To change colors of individual letters in a text segment:

1 Using one of the text tools, select a text segment.

The selection frame and letter beads appear on the text.

If you hover over a color square on the Palette, the thread type and 
number will show beside the mouse pointer.
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2 Select the letter you want to change by clicking on its letter bead 

(blue square superimposed on the letter).

The letter is enclosed in a selection frame.

3 Click a color in the Color Palette to change the color of the letter.

The letter will change to the selected color.

4 Repeat steps 2 – 3 for each letter you want to change.

5 Click elsewhere in the workspace to de-select the text.

Creating Multi-color Text Segments 
When you are creating design compositions involving lettering, you 

may find that you want to have two or more colors in a single line of 

text. In BES Blue, this can be easily done using the Properties Panel.

You accomplish this by inserting a special character, the tilde (~) into 

your text. Inserting these characters divides your text segment into 

sub-segments; each of the sub-segments that are created this way 
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gets its own color identifier label (Color1, Color2, etc.) and can then be 

assigned its own thread color on the Color Palette.

To insert thread color changes within a text segment:

1 Select the text segment.

2 In the Text field of the Text Properties Panel, type a tilde (~) 

between letters in each position that you want a color change to 

occur.

3 Click Apply.

You see the colors change for all text sub-segments after the first 
one, which retains the original color.

The text segment, as it appears initially, after being divided into sub segments. The 
first sub-segment retains the original color, and the subsequent ones are assigned 
arbitrary “placeholder” colors (until you chose your own).

Alternatively, you can click the Auto Insert Color Change  button in 

the properties panel to insert a color change between each letter. 
See “Auto-inserting Color Changes into Text” below.
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4 To apply your choice of colors to the sub-segments, move the 

mouse pointer to the desired color in the Color Palette and left-

click. 

A context menu appears, listing the text sub-segment color 
identifiers in the order they appear in your text.

Selecting the colors for the individual sub-segments; in this example, applying a red 
thread color to the first segment, the word ‘Multi”.

5 From the context menu, click on the sub-segment identifier to apply 

the chosen thread color to it. 

The sub-segment changes to the chosen color.

6 Repeat step 5) for each sub-segment in your list.

The text segment with new thread colors applied.

Changing Colors in a Two-color Font
You can also choose the thread color for each of the components (that 

is, the fill and the border) of a two-color font. You apply the color to 

each by selecting the color you want to use for each from the color 

palette. 

To change colors in a two-color font:

1 Create a text segment, using any of the Text tools.

The example outlined above demonstrates two color changes being 
applied between words, but you can apply changes in exactly the 
same way between individual letters in a word. Note that the tildes do 
not add any space between characters or words in your text.
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2 In the Properties box, select a two-color font (e.g. 2Cl Team 

Medium) and click apply.

The text segment, appears in the workspace; colors for the fill and 
border are chosen arbitrarily.

3 Find the color you wish to apply to the fill of the lettering segment 

in the color palette, and left-click on it.

You see the following Options menu.

4 In the Options menu, click on Color 1.

The fill color of the lettering changes to the chosen color.

5 Find the color you wish to apply to the border of the lettering 

segment in the color palette, and left-click on it.

6 From the Options menu, click on Color 2.

The border color of the lettering changes to the chosen color.
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Auto-inserting Color Changes into Text
The Auto Insert Color Change feature is another way to quickly and 

easily create multi-color text. This tool automatically inserts a color 

change between each letter in the selected text. 

To auto-insert color changes in a text segment:

1 Select a text segment.

2 In the Text field of the properties panel, click the Auto Insert Color 

Change  button.

3 Click Apply.

A color change will be placed between each letter in the text 
segment.

You can also apply the border color first, and then the fill color; 
the order you make the change in makes no difference.
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4 To change the colors of individual letters, move the mouse pointer 

to the desired color in the Color Palette and left-click. 

A context menu appears, listing the color changes in the order they 
appear in your text.

5 From the context menu, click the appropriate color change number 

to apply the chosen thread color to it. 

The letter changes to the chosen color.

6 Repeat steps 4- 5 for each sub-segment in your list.

In the properties panel, note that the color changes will appear as 
tildes (~) between each letter. If you want to have fewer color 
changes in the text, you can achieve this by manually deleting 
some of the tildes in the text field; click Apply to see the changes. 



Topics covered in this chapter:

• Editing text objects using Properties Panel settings.

• Using the Styles feature to give a different look to your lettering.

• How to know what characters are available in each font.

• The Spell Checker feature.

• Using the color palette.

CHAPTER 3:

Text Properties
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The Properties Panel
The BES Blue Properties Panel appears on the right of the workspace. 

This panel displays, and allows you to modify, all the properties 

associated with the lettering in your designs. These include the text 

properties, the fill properties, underlay properties, and Pull 

Compensation properties. Each of these types of properties has its 

own section in the Properties Panel, and each will be discussed in 

detail in its own section to follow.

Adjusting Text Properties
The Properties Panel allows you to modify various properties of the 

currently selected text segment. You can use this area of the panel to 

change text itself, choose a font, and select the height, alignment, and 

spacing of the letters. You can also alter the sewing sequence, and 

determine how trims and lock stitches will be applied to the segment.

The properties that you will see displayed will be slightly different 

depending on which type of text is currently selected.

If you need to make room in the Properties Panel in order to see some 
of the fields better, you can collapse one or more areas by clicking the 
small minus sign next to its name; the box will then display a small plus 
sign. Clicking on the plus sign expands that area again. 

The property fields you see in the text area may be different, depending 
on which kind of text frame is selected; for example, when a Circle 
frame is selected, this area will show two places where you can input 
text, labelled ‘Upper’ and ‘Lower’.

After making any changes involving the Text Properties Panel, click the 
Apply button at the bottom of the panel to apply them.
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Changing the Text
As well as being able to type directly on the screen (see appropriate 

sections under “Creating Text”), you can also input your text by typing 

it into the Text field on the Properties Panel. Note, however, that there 

is some variation on what you can type, depending on which kind of 

Frame is selected. For example, multi-line text segments can only be 

entered when a Normal Text frame is selected. 
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To edit text in the Properties Panel:

1 Select the text object you want to edit.

2 In the Text area of the Properties Panel, click in the Text field to 

select it.

3 Type the desired text into the Text field.

4 Click Apply to save your changes.

Changing the Font of Existing Text 
You can change the font type of text objects using the drop-down list of 

fonts in the Properties Panel. At the top of the area, you see a preview 

image showing a sample of the selected font.

You can choose from two types of fonts at the outset; embroidery fonts 

or TrueType fonts. The default list of fonts you see in the Text area will 

be embroidery fonts; to show the TrueType fonts, check the box next 

to TTF.

Note that, depending on the embroidery font you choose, there are 

different minimum and maximum height recommendations. For more 

information, see “Displaying font properties.”

If the Properties Panel is not already visible, you can display it 
quickly by pressing Alt + Enter on your keyboard.

When TrueType fonts are used for embroidery letters, the satin 
stitches that comprise them will sew out horizontally.



Text Properties 93
To change a font type:

1 Select the text segment you want to alter.

2 In the Text Properties area, in the TTF field, do one of the 

following: 

 To choose from the selection of Embroidery fonts, leave the 
TTF checkbox unchecked.

 To choose from the selection of TrueType fonts, check the TTF 
checkbox.

The list of available fonts will change accordingly.

3 From the Font list, select the font you want to use.

4 Click Apply to save your changes.

You see your text’s font type altered accordingly.

Displaying a Font’s Available Characters
In Properties Panel, there is a tool which displays all the characters 
(keystrokes) that can be entered for available embroidery fonts. For 
example, some fonts only allow you to enter uppercase characters, 
while other fonts allow you to enter both uppercase and lowercase 
characters. The available characters box also tells you the minimum 
and maximum recommended heights for sewing out the font.

To display an embroidery font’s available keystrokes:

1 In the Text area of the Properties Panel, select the font you want to 

use in the Font field.

2 Do one of the following:

 Click on the available characters button  to the immediate 

left of the font field.

 Hover the mouse pointer over the font preview image at the top 
of the Properties Panel.

A new window displays all the available keystrokes.

You can preview the fonts available by clicking the arrow to the right of 
the font name. This will display a drop-down list of the available fonts; 
scroll through the list by dragging the track button. You can click on 
each font name to display a preview of the font in the Text area.
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Spell Checker 
The Spell Checker feature is found in the Properties Panel in BES 

Blue.

To use the Spell Checker feature:

1 Create a text segment.

2 Click the Spell Checker button  in the Text field on the 

Properties Panel.

The spell check dialog appears. Any word that is misspelled will be 
shown in red.

Note that Spell Checker uses the Microsoft Word spell check function, 
so it only works on computers that have Microsoft Word installed.
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3 To see a list of suggested correct spellings, right-click in the text 

entry box next to the incorrect word.

A list of alternatives appears beside the misspelled word.

4 Click on the correct word that you want to replace the incorrect 

one, or directly type over the incorrect word to replace it. 

Your choice replaces the incorrect word.

5 Click Apply to create the text segment in your workspace.

The corrected text appears in your workspace.

Changing the Height of Lettering
With BES Blue, it is easy to change the height of any lettering. Height 

refers to the tallest character in the desired lettering. So, when a text 

segment contains both uppercase and lowercase letters, it is the size 

of largest uppercase letters (usually) that is set by this property.

To change the height of lettering:

1 Select the text object you want to alter.

2 In the Text area of the Properties Panel, select the Height field.

The property label (Height) is highlighted in blue. 

3 Type in the height you want your letters to be.

4 Click Apply to save your changes.

You see your text’s height altered accordingly.
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Changing Font Spacing
The font spacing property controls the horizontal spacing between 

letters in a text segment. The normal (default) value for the font 

spacing is zero. You can set the font spacing to a negative or a 

positive value. If you set the value to less than zero, then the spacing 

between letters decreases; if you set the value to greater than zero, 

then the spacing increases.

Notice that the spacing property applies to the whole segment. If you 

want to change the spacing selectively, to individual gaps between 

letters, you can use the Kerning Handles.

To change font spacing:

1 Select the text object you want to alter.

2 In the Text area of the Properties Panel, click in the Spacing field to 

select it.

3 Enter the font spacing value you want to use.

4 Click Apply to save your changes.

You see your text’s letter spacing altered accordingly.

Width Percentage
The Width Percentage changes the overall width of a text segment. 

You can adjust the Width Percentage to alter the appearance of the 

text object, or to allow it to fit the hoop better.

To change Width Percentage:

1 Select the text object you want to alter.

2 In the Text area of the Properties Panel, select the Width field.

3 Enter the Width Percentage value you want to use.

4 Click Apply to save your changes.

You see your text’s Width Percentage altered accordingly.

When you change the width of a segment using the Width Handle, the 
Width Percentage of the selected segment will be adjusted 
automatically to reflect the change.
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Changing the Slant Setting
BES Blue allows you to use the Slant setting to create a slanted effect 

in text objects. Slant changes the degree value of the slant on your 

lettering. A negative value slants your lettering to the left; a positive 

value slants it to the right.

To change slant settings:

1 Select the text object you want to alter.

2 In the Text area of the Properties Panel, enter the slant value you 

want to use. To slant your lettering to the left, enter a negative 

value. To slant your lettering to the right, enter a positive value.

3 Click Apply to save your changes.

You see your text altered accordingly.

Negative slant to the left and positive slant to the right.

Applying an Envelope
One way to vary the shape of your text segment is to use the Envelope 

setting. This allows you to apply a predefined envelope to change the 

shape of a Normal Text or Monogram text item.

To apply one of the pre-determined envelope shapes:

1 Select the item with the Text tool, and press ALT + Enter to show 

the Properties Panel, if it is not already visible.

2 In the Text area of the Properties panel, click on the Select button 

next to “Envelope.” 

The Envelope window will open.
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3 Select one of the envelope shapes from the list.

The selected envelope shape will be applied to your lettering.

Sew sequence
This setting determines the position in the text segment at which the 

sewing will begin. Choose between Left, Right or Center.

Adding Trims
Use the Trims field to control how trims are applied to lettering 

segments. You can choose from the following options:

• Always: Inserts a trim between all letters in the segment.

• Never: No trims are placed between letters in the segment

• Auto: A trim is placed between letters if the distance between them 

exceeds a predetermined minimum length.

Adding Lock Stitches
You can choose to add lock stitches to the selected text segment. 
Each lock stitch is a set of four short overlapping stitches in a line, 
which secures the end of a column or fill stitch. Select one of the 
following options:

• Always: Locks will be added at the either end of each letter in the 
segment, whether there is a trim or not.

• Never: Lock stitches will not be added at any point.

• Around trim: Lock stitches will be added at either side of trims. 
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Setting Connection Distance
Use the connection type settings to choose the way that letters are 

connected in lettering. The connection types are As Digitized, Closest 

Point, and Furthest Point.

To set the Connection type:

1 In the Text area of the Properties Panel, select one of the following 

from the Connection list:

 Select As Digitized to connect lettering using the original 
digitized order.

 Select Closest to have the connections move to the closest 
point between letters.

 Select Furthest to have the connections move to the furthest 
point between letters.

2 Click Apply.

The connections will be adjusted accordingly.

Drop Caps
Drop Caps is a property that can be modified through the Text area of 

the Properties Panel. It can be used to change the height and vertical 

alignment of the letters at the beginning of the selected text. There are 

two settings relating to the Drop Caps Property - Alignment and 

Percentage.

Use the Alignment option to determine the position of the baseline of 

the relative to the main lettering. See the examples below, showing 

Top and Baseline alignment of the Drop Cap letter respectively.
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The Percentage property determines how much bigger than the main 

segment the Drop Cap letter will be. This value is expressed as a 

percentage, with 100% being equal in size to the main lettering.

Properties Specific to Particular Text 
Frames
Decor for Monograms

Most of the properties of a Monogram are the same as the ones that 

appear for Normal text; the exception is the Line Spacing property, 

which does not apply. There is an additional feature unique to the 

Monogram properties section, called Decor. Decor consists of pre-

designed embroidery that frame the monogram text.

Example of the monograms made using the Decor Monogram fonts.

Some of the fonts that are installed with the software do not have 
the capability of working with drop caps; for these, the setting will 
be inactive in the Properties Panel.

Decor is only available when the Monogram is created using the special 
monogram fonts that support it; these are the ones labelled Decor 
Monogram in the list of fonts. 

You can create a monogram font using another kind of font, but in this 
case, the Decor option will be unavailable.
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If you create your monogram using one of the special monogram fonts, 

you will see that the Decor Field is active. 

To choose the decor type for your monogram, you first create a 

monogram segment, and choose a Decor Monogram style in the font 

area (see “Creating Monograms” in the “Creating Lettering” section of 

this manual). Click the down-arrow to the right of the decor field, select 

a decor from the list, and then click Apply.

Line Spacing

The Line Spacing parameter only applies to the Normal text mode. 

This property controls the spacing between lines in multi-line text 

segments. This quantity is expressed as percentage of the Letter 

Height value.

Align

The Align setting is found only in Normal text mode and can be applied 

to lettering segments with more than one line. You can align your text 

on the left, right, or center.

Changing Properties with the Context 
Menu (Right-click)
You can right-click on any text object, regardless of its type, and an 

edit menu will appear. This menu allows you to change several 

important text properties, such as changing or resetting frames.

Changing Text Modes

The Text Mode can be changed for an existing text object in BES Blue. 

You can change an existing text item to Normal, Path, Vertical, Circle, 

Monogram, Spiral, or Step Text frame type. Right-click the text object 

and select a text mode from the menu.

If you want to use one of the Decor Monogram fonts without the decor, 
there is the option to do so; just select decor option “00”, which is at the 
top of the list, and essentially means that no decor is added.
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This feature is useful when the text is already in position, but you want 

to change the frame that is applied to it. For instance, you may create 

a normal text object, but then realize you want it to be an Circle text 

object instead.

Resetting the Frame

The Reset Frame command is useful when you have altered your text 

object a bit too much and want to start over. For details on the 

procedure, see Creating Text—Text Frames-An Overview—Reset 

Frame.

Resetting Individual Letters

If you have selected a single letter in a text segment, the context menu 

will have an additional option, the Reset Letter command. Use this 

command in cases where you have manipulated a letter and want to 

reset it so that it looks as it would if it was never individually adjusted.

This command is available when you activate individual letter 
size handles and right-click the individual letter with your cursor.
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Changing Text Direction (Circle Text)

Initially, when you create a Circle text segment, the letters will start at 

the top, and read clockwise around the circle (this is ‘Text Direction 

Normal’). However, if you want the text to start at the bottom and read 

counter-clockwise instead, you can right-click the segment and 

choosing Text Direction Reverse from the menu that appears.

Changing Text Direction (Spiral Text)

The text in a Spiral text segment can be set to run outwards from the 

center, or from the outside edge inwards.

• To change the text direction, select the Spiral segment, right-click, 
and select “Inwards” or “Outwards” from the context menu.

Style Property for Text
There is the option in the Properties Panel, for those fonts that support 

it, to change the style of the embroidery that is used to draw your 

lettering. Styles is an option which you can use to expand the creative 

possibilities of embroidery lettering.

Styles cannot be applied to all the available fonts, only those that have 

been digitized to include outlines. In the drop-down list of embroidery 

fonts, these are marked with a special “outline” symbol next to the 

font’s name, like this: .

To get text that goes in both directions, within a single Circle text 
segment, type text directly into the Circle text properties page: ‘Normal’ 
direction into the Upper text box, and ‘Reverse’ text into the Lower text 
box. 
If you have text in both the upper and lower text fields, changing the 
text direction will swap the positions of the two text strings, so you will 
not have to re-enter them manually.

Applying the different styles to text will not always produce good 
results for all letter heights. 

TrueType fonts can also have styles applied to them. However, for 
TrueType, the style options are Standard Fill, Column, and Run Only. 
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Run Style
When you apply the Run Style to the text segment, it converts the 

outline of the lettering to a run stitch. The potential options are stitch 

length and run stitch type.

There are three different Run Stitch types available: Single, Double, or 

Motif. Choose the option you want to apply in the “Run” area of the 

properties panel (you may have to scroll down and expand this area in 

order to see these options):

• A Single Run stitch is a simple forward-moving stitch that looks 

like any straight stitch produced by a sewing machine. 

• A Double Run stitch sews over the line twice: once forward, and 

once backward, thus it ends up where it starts.

• The Motif Run is a decorative, programmed stitch which usually 

has an open, ‘lacy’ look. When you select the Motif run option, the 

list of Motif patterns at the bottom of the Run area in the Properties 

becomes active. Scroll down the list to select the Motif you want.

In addition, if you opt for the Single Run type in the above step, the 

Run Style property becomes active. This has two additional options:

•  Bean: Generates a running stitch where the machine sews over 

each stitch three times (forward, back, forward again) before it 

moves to the next stitch. The result is a heavy running stitch.

• Half Bean: This is a running stitch that creates a slightly different 

effect than the standard Bean stitch. In Half Bean stitches, the 

needle penetrations are slightly displaced on the back stitch, so 

that they do not match up exactly for each stitch as they do for the 

regular Bean stitch. 
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Steil Style
This style applies a Steil border to the outline of a text segment. Steil is 

a constant-width satin stitch which follows the outer contour of each 

letter, The properties specific to Steil are width and density.

Appliqué Style
If you need to create large letters, Appliqué Style text is one way to 

reduce the number of stitches required. With Appliqué Lettering, you 

use cut pieces of fabric in place of large fill stitch areas.

There are three different embroidery segments for each letter in 

appliqué style text:

• Positioning stitches. These sew onto the garment first, and serve 
as a guide for placing the appliqué fabric.

• Tack-down stitches. Once you have place the appliqué fabric, the 
tack-down stitches hold it in place.

• The Appliqué border. Border stitches run all the way around the 
outline of each letter to securely attach the Appliqué fabric to the 
garment. There are three different kinds of border stitches 
possible, Satin, Motif, and Blanket. For more information about 
each of these types, see the procedures for each type, below.
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Standard with Steil Style
Like the Steil Style, the Standard Fill with Steil Style converts the 

outline of the text to a Steil border stitch. However, in this style, the 

text segment also has a standard fill in the middle of the lettering.

Motif with Steil Style
The Motif with Steil text style converts the outline of the lettering to a 

Steil stitch, which is sewn over top of a Motif Fill.

You can adjust the pattern, pattern size, and stitch length of the Motif 

Fill in the Fill area of the Properties Panel. The width and density of 

the Steil border can be adjusted in the Steil area of the Properties 

Panel.

The Standard Lettering properties, such as Fill, Underlay, and Pull 
Compensation also apply to Steil. For more information about these 
properties, see “Changing Lettering Properties”.
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Adjusting the Settings for Appliqué 
Style Text

Satin Settings 

You can modify the settings and make all changes to the satin stitches 

in the Appliqué box. 

To adjust Satin stitch settings for Appliqué: 

1 Select the Appliqué text segment.

2 In the Properties Panel, in the Appliqué type field, select Satin.

3 Adjust any of the following settings in the Properties Panel:

 In the Stitch Length box, enter the stitch length of the 
positioning and tack down runs.

 In the Appliqué Width box, enter the width of the Satin stitching.

 In the Appliqué Density box, enter the density of the Satin 
stitching.

 In the Inset box, set the Inset percentage value. The Inset 
percentage determines how far the tack-down stitch of the 
appliqué is inset, relative to the border.

4 Click Apply.

Adjusting Blanket Settings for Appliqué Style Text

After you select the Appliqué stitch type, you can adjust any of the 

default settings available. You must make all changes to the Appliqué 

stitches from the Appliqué box.

To adjust blanket settings for Appliqué:

1 Select the Appliqué text segment.

2 In the Properties Panel, in the Appliqué type field, select Blanket.

3 Adjust any of the following settings in the Properties Panel:

 In the Stitch Length box, enter the stitch length of the 
positioning and tack down runs.

 In the Appliqué width box, enter the width of the Blanket 
stitching.

 In the Blanket density box, enter the spacing for the Blanket 
stitching.

4 Click Apply.
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Adjusting Motif settings for an Appliqué Border

After you select the Appliqué stitch type, you can adjust any of the 

default settings available. You must make all changes to the Appliqué 

stitches from the Appliqué box.

To adjust Motif settings for Appliqué:

1 Select the Appliqué text segment.

2 In the Properties Panel, in the Appliqué Type field, select Motif.

3 Adjust any of the following settings in the Properties Panel:

 In the Stitch Length box, enter the stitch length of the 
positioning and tack down runs.

 In the Inset box, select a percentage to inset the edge of the 
appliqué border, relative to the outline of the lettering.

 From the Motif list, select a Motif pattern that will be used as 
the Appliqué stitching.

 In the Motif Stitch Length box, enter the motif stitch length. The 
motif stitch length affects the size of the motif and represents 
the length (width) of each motif pattern. 

4 Click Apply.
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Fabric Backgrounds in Appliqué Style Text

You have the option of selecting a fabric background to display within 

the appliqué border. You can select either from a list of fabric images 

provided with BES Blue, or import your own image file to use as a 

background.

To display a fabric background in an Appliqué segment:

1 Select the Appliqué text segment.

2 In the Appliqué area of the Properties Panel, select the Fabric 

field.

3 In the Fabric field, click Select...

The Fabrics dialog pops up in front of the workspace.

4 Select a fabric from the dialog by clicking on its swatch.

5 Click Ok.

The selected fabric image appears within the Appliqué border.
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To import an image for an Appliqué background:

1 Select the Appliqué Style segment.

2 Open the Properties Panel.

3 In the Appliqué area click Select... in the Fabric field.

The Import Fabric dialog will open.

4 In the Fabrics dialog, click the Add... button. 

5 Browse to the location of the image you wish to use as a fabric.

6 Select the image and click Open.

The image appears within the Appliqué border, and it is added to 
your Appliqué Fabric list.

Changing colors in Appliqué Text
In order to stop the machine so that you can place the fabric pieces to 

be sewn on to the garment, the Appliqué Style lettering segment 

inserts a color change between each positioning, tack-down, and 

border segment. This means that, when first generated, the lettering 

segment will display many colors.

The fabric image you apply in the Properties box will also be 
visible in the print-out of the design.

You can scan your own images of fabric swatches for use in your 
design projects. For best results, scan them with a resolution of 300 dpi. 
A 1 in. × 1 in. piece of fabric should be sufficient for your sample. 

The fabric image you import will also be visible in the print-out 
of the design.
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You can change the colors of lettering in a Appliqué segment by 

selecting a color from the list on the Color Palette.

To change the color of letters in an Appliqué Text segment:

1 Select the Appliqué Text segment.

2  In the color palette, find the color you wish to apply to the first of 

the letter of segment, and click on it.

You see the a menu of colors.

3 To set the color of the first letter, in the Options menu, click on 

Color 3. (In the first letter of an Appliqué-style text segment, Color 

In the normal sewing-out of a Appliqué text segment, the machine will 
not stop between the border stitches of one letter and the positioning 
stitches of the subsequent one; so, the last color of one letter (the 
border stitches) will be the same as the first color of the next (that 
letter’s positioning stitches).

However, you can force the segment to stop between letters by 
inserting the tilde symbol (~) between letters. (In the example below, 
you would type B~E~S.) If you add these stops, there will be three 
stops for each letter, and changing every third thread color will change 
the color of the corresponding letter.
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1 refers to the positioning stitches, and Color 2 to the tack-down 

stitches; Color 3 is the thread color of the visible border stitches).

The first letter changes to the chosen color.

4 Choose the color you wish to apply to the next letter and click on it.

5 From the menu, click on Color 5. (For the second letter of the 

appliqué segment, the positioning stitches will be sewn using 

thread color 3, and the tack-down stitches color 4).

The second letter will change to the chosen color.
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6 Repeat steps #4 and #5 for each letter in the segment, changing 

every other color in the appliqué segment, until you have changed 

all the colors required.

Adjusting Fill Settings
In the Properties Panel, you can customize the parameters used by 

BES Blue when it generates the fill stitching for the segment. You have 

the option to add a pattern type and change the text object’s density 

settings.

Choosing a Fill Pattern
When you install BES Blue, a wide variety of Standard and Carved 

patterns are installed along with the software. You can select which 

Standard or Carved pattern to use in the Properties box.

To choose the fill pattern:

1 Select the Lettering segment.

Alternatively, you can change colors by expanding the Appliqué 
segment in the Sequence View. Then, each portion of the appliqué 
(positioning, tack-down, and border) can be selected individually. 
Then, you can change the color of the selection by clicking on the 
desired color in the color palette.
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2 In the Fill area of the Properties box, in the field labelled Fill Type, 

select either Standard or Carved.

3 Click on the down arrow on the right of the Pattern field to display a 

drop-down list of patterns.

You see a list of patterns; the patterns that are displayed depend on 
the type of fill you chose in step 2.

4 From the Pattern list, select a pattern.

5 Click Apply.

The fill of your text segment is altered accordingly.

Fill Density Setting
Fill density is the distance between individual lines of embroidery. 

Density is measured in millimeters.

Use the density setting to adjust your fill to suit the fabric you are 

sewing on. For example, fabrics with a very loose weave are less able 

to hold a large density of stitches; in cases such as this, you can lower 

the density of the fill.

If you are unsure what setting to use, try the standard setting of 0.4. 

This setting works well almost universally, as long as you have not 

exceeded the font’s size recommendations.

Note that the density setting is given in millimeters. Therefore, larger 
values correspond to a lower density, while lower values correspond to 
a higher density. For more details on stitch density units, see “Density” 
in the Glossary.
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In the Fill area, the image beneath the Density setting will change as 

you adjust the setting. These are not precise images; rather, they are 

intended to provide you with visual cues to what you are doing as you 

change the settings.

If the letters in the text segment are large (i.e., above the maximum 

recommended height for the font) it is better to use a fill, rather than 

satin, for the lettering. Fill stitches are the type you would normally find 

filling an area in an embroidery design. With Fill stitches, each line 

across is made up of two or more individual stitches.

Carved Fill Properties
In addition to the density and stitch-length settings described above 

there are a few extra fill settings that apply only to the Carved fills. You 

can adjust these Carved pattern settings in the Properties box. The 

settings allow you to change a fill pattern’s characteristics such as the 

size and angle of the fill pattern.

The following figures show some different effects you can create using 

the Carved Fill settings.

To change the Emboss Scale of a Carved pattern:

1 Select a Carved fill segment.

2 In the Fill area of the Properties Panel, do the following:

 Click the Emboss Scale box to select this property.

A general rule is to go for full-fabric coverage, but add extra stabilizer if 
you want to support a high-density fill on a low-density fabric.

Original (scale at 100%) Emboss Scale at 50%
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 In the Emboss Scale field, enter a percentage value to adjust 
the scaling.

3 Click Apply.

To change the Emboss Angle of a Carved pattern:

1 Select a Carved fill segment

2 In the Fill area of the Properties Panel, do the following:

 Click the Emboss Angle box to select this property.

 In the Emboss Angle field, enter a percentage value to adjust 
the angle.

3 Click Apply.

You see your segment altered accordingly.

Underlay Properties
Underlay stitches are laid down before the visible, or “top” stitches, to 

help stabilize stretchy fabrics. They can also help to tack down wales 

or naps (on fabrics such as corduroy).

There are a variety of possible underlay types available; the following 

image gives a schematic view of how the different types of underlay 

are sewn.

The Underlay Area in the Properties Panel.
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Selecting the Underlay Type
You can select Underlay types for various types of stitches. Choose 

from Contour, Perpendicular, Lattice, Full Lattice, Parallel, or Zig-Zag. 

You can combine underlay types to get maximum coverage.

To select an Underlay type:

1 Select the segment.

2 In the Properties Panel, scroll down to the Underlay area.

3 Select one or more of the available Underlay types.

4 Adjust any of the other settings. Refer to the related procedures for 

more information.

5 Click Apply.

Specifying the Underlay Density
You can specify the density for underlay stitches.

To set the Underlay Density:

1 Select the segment.

2 In the Properties Panel, scroll down to the Underlay area.

3 Select one or more of the available Underlay types.

4 In the Density box, enter a density value.

5 Adjust any of the other settings. Refer to the related procedures for 

more information.

6 Click Apply.

Specifying the Underlay Stitch Length
You can specify the stitch length for your Underlay stitches. You can 

increase or decrease the length according to your underlay needs.

Note that not all Underlay types will be available for text; in 
particular, Lattice and Full Lattice Underlay will not be available 
for text segments.

When you select Underlay types, you will be able to see what 
your Underlay type will look like in the Preview area.
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To specify the Underlay Stitch Length:

1 Select the segment.

2 In the Properties Panel, scroll down to the Underlay area.

3 Select one or more of the available Underlay types.

4 In the Stitch Length box, enter the stitch length that you want for 

your Underlay stitches. 

5 Adjust any of the other settings. Refer to the related procedures for 

more information.

6 Click Apply.

Changing the Inset Distance
You can change the Inset Distance. BES Blue calculates the Inset 

Distance (the distance the underlay stitches are placed from the edge 

of the top stitching.) Inset Distance changes the amount of underlay 

coverage. The smaller the Inset Distance, the more coverage you 

have.

To change the Inset Distance:

1 Select the segment.

2 In the Properties Panel, scroll down to the Underlay area.

3 Select one or more of the available underlay types.

4 In the Inset box, enter the amount of distance you want. 

Enter a zero value if you want to place the underlay directly on the 
edge of the segment.

5 Click Apply.

When you select Underlay types, you will be able to see what 
your Underlay type will look like in the Preview area.

When you select Underlay types, you will be able to see what 
your underlay type will look like in the Preview area.
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Pull Compensation Settings
BES Blue allows you to adjust the Pull Compensation in your design, 

through the Properties tab. There are two types of Pull Compensation, 

which differ in the way that the Pull Compensation is determined. 

• A Percentage Pull Compensation calculates the change made to 

the stitches’ width based on their original width. 

• An Absolute Pull Compensation is simply an extra amount of width 

which is added to the stitches regardless of their original length.

To adjust the Pull Compensation:

1 Select the item you want to adjust.

2 Press ALT + Enter to display the Properties Panel, if it is not 

already visible.

You see the Properties Panel.

3 In the pull compensation area of the Properties Panel, click the 

down arrow to the right of the Type field.

4 A list of options is displayed.

5 Select one of the following options:

 None. Makes no adjustments to pull compensation.

 Percentage. Enter the percentage in the Value % box and, if 
necessary, enter the maximum value of pull compensation in 
the Max Range box.

 Absolute. Enter the amount of absolute pull compensation (in 
mm) in the Absolute Value box.

6 Click Apply.

When you use Percentage Pull Compensation, you can also enter a 
value in the Max range box of the Pull Compensation area. This value 
sets an absolute maximum limit on the size of the Pull Compensation. 
If the calculated Pull Compensation value goes over this length, the 
actual stitches that are generated will be limited to this length.
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Displaying Special Characters
When you create lettering, you can enter characters available on your 

keyboard. You can also enter characters using ASCII numbers, a 

feature that is available for you to use if required. An ASCII number is 

a code number, four digits long, which represents a character that 

does not have a key to represent it. For instance, ™ or ® are symbols 

that exist in some fonts but are not type-able on a standard US/English 

keyboard. 

Please note that not all fonts contain all of the special characters. To 

see which characters are available in any given font, check the font 

preview information for that font.

Special Characters List

The following lists the special characters that may be available in BES 

Blue.

Due to Windows constraints, you must enter the numbers on the 
keyboard’s numeric keypad for this to work.

If you are working from a laptop computer, you will have to enable the 
keypad in order to use it to input special characters; see your 
computer’s documentation.

You can see the list of available characters for a font by pressing on 

the  button in the Font field of the Text Properties Panel, or by hov-

ering your mouse over the font preview.

Character Key Code

€ Alt + 0128

‘ Alt + 0145

’ Alt + 0146

“ Alt + 0147

” Alt + 0148

Alt + 0149

— Alt + 0151

Alt + 0153
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¡ Alt + 0161

¢ Alt + 0162

£ Alt + 0163

¤ Alt + 0164

¥ Alt + 0165

¦ Alt + 0166

§ Alt + 0167

Alt + 0168

© Alt + 0169

- Alt + 0173

® Alt + 0174

¯ Alt + 0175

¿ Alt + 0191

À Alt + 0192

Á Alt + 0193

Â Alt + 0194

Ã Alt + 0195

Ä Alt + 0196

Å Alt + 0197

Æ Alt + 0198

Ç Alt + 0199

È Alt + 0200

É Alt + 0201

Ê Alt + 0202

Ë Alt + 0203

Ì Alt + 0204

Í Alt + 0205

Î Alt + 0206

Ï Alt + 0207

Ð Alt + 0208

Ñ Alt + 0209

Character Key Code
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Ò Alt + 0210

Ó Alt + 0211

Ô Alt + 0212

Õ Alt + 0213

Ö Alt + 0214

× Alt + 0215

Ø Alt + 0216

Ù Alt + 0217

Ú Alt + 0218

Û Alt + 0219

Ü Alt + 0220

Ý Alt + 0221

Þ Alt + 0222

ß Alt + 0223

à Alt + 0224

á Alt + 0225

â Alt + 0226

ã Alt + 0027

ä Alt + 0028

å Alt + 0029

æ Alt + 0230

ç Alt + 0231

è Alt + 0232

é Alt + 0233

ê Alt + 0234

ë Alt + 0235

ì Alt + 0236

í Alt + 0237

î Alt + 0238

ï Alt + 0239

ð Alt + 0240

Character Key Code
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To type special characters:

1 In the text frame, position the cursor where you want to insert the 

special character.

2 Press and hold down the ALT key on your keyboard.

3 Type the corresponding key code for the special character from the 

number pad located on the right side of the keyboard.

To view a list of special characters and their corresponding key 
codes, see "Special Characters List".

4 Release the ALT key on your keyboard.

You see the special character.

ñ Alt + 0241

ò Alt + 0242

ó Alt + 0243

ô Alt + 0244

õ Alt + 0245

ö Alt + 0246

÷ Alt + 0247

ø Alt + 0248

ù Alt + 0249

ú Alt + 0250

û Alt + 0251

ü Alt + 0252

ý Alt + 0253

þ Alt + 0254

ÿ Alt + 0255

Character Key Code
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Once you have learned to create your own designs, you will want to 

create and save them as files to output to your machine. BES Blue 

allows you to save to a number of machine formats.

Topics covered in this chapter:

• Saving designs, and the different stitch file types that are available.

• Selecting, copying, and pasting components of the design.

• Moving and aligning items in your workspace.

• Combining lettering with other designs using the Merge Design Files 

feature.

CHAPTER 4:

Editing Designs
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Creating New Designs
When you open BES Blue, you can immediately begin creating a new, 

untitled design in the design window. The design window automatically 

opens using the default recipe and machine format settings specified 

in the Preferences dialog. For more information on default settings, 

see “Setting up your Workspace Environment.”

If you want to open a design and apply a different recipe to it (that is, 

not the default recipe), you will want to open using the New Project 

tool. 

To create a new design using the recipe dialog:

1 Click the Accelerator button , hover over New, and then click 

the New Project  tool.

You see the New Project dialog.

2 Enter a name for the new project in the Project Name field.

3 In the Recipe list, select the recipe you want to use for your design.

If you select the New tool from the Quick Access toolbar, you will 
bypass the recipe selection dialog. A new design window will open 
using the default recipe and machine format settings.

The Recipe description box in the dialog gives you a brief description 
of each recipe as you scroll through the list in the Recipe drop-down 
list. 
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4 In the Machine format list, select the machine format that you want 
applied to the design when created.

5 Click OK. 

You see a new design window.

Opening and Closing Designs
BES Blue allows you to open designs in a wide variety of file formats. 

When you open a design file in the design window, your single design 

file retains the stitches for that design.

To open an existing design:

1 Do one of the following:

 Click the Open  tool on the Quick Access toolbar

 Click the Accelerator button  and select Open from the 

menu.

You see the Open Design dialog box.

2 In the Look in list, browse to the location of the file you want to 

open.

3 In the Files of type list, select the format for the design you want to 

open.

4 In the File name box, enter the file name, or select the file you want 

to open by clicking the file.

5 Select Preview to view a thumbnail of the design. 

6 (Optional) Check the Convert to Outlines box. If this option is 

selected, the design’s stitch segments will be converted to outlines, 

allowing you to select the segments individually in the Sequence 

View. Once you have converted, you can save the file as a *.BRF.

7 Click Open.

To view the contents of a zip (compressed) file, select the zip file and 
click Open. Select the design you want to open from the unzipped file 
list and click OK.

To open a file you have recently worked on, click the Accelerator 

button  and locate it in the “Recent file list.”
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To close a design:

• Click the Accelerator button , and select Close  or Close All 

 from the menu.

Opening Files with the Browser
The Browser is a very convenient way to search for and open files. It 
allows you to search for and open embroidery files from multiple 
directories simultaneously.

So, if you have designs stored on a number of different media - e.g. a 
CD, a USB device, as well as on your hard drive - you can look in all of 
these places at once with the Browser feature. The Browser displays a 
preview image of the design in its preview pane, plus the design’s 
name, dimensions, stitch count, and the number of colors that it uses.

You can also use the Browser dialog to merge a design into the current 
design. (For more information, see “Merging Design Files.”)

To open files using the Browser:

1 Click the Accelerator  button, and select the Browser  tool.

You see the (empty) Browser window.
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2 Click in the check boxes next to the directories you want to browse 

for designs; to look in multiple locations, simply check more boxes.

3 By default, the search will only include those folders that are 

checked in the list on the left of the browser window. However, you 

can use the following options to expand the scope of the Browser’s 

search:

 To convert stitch segments to outlines, check Convert to 
outlines. If this option is selected, the stitch segments will be 
converted to outlines, allowing you to select them individually in 
the Sequence View.

 To include all folders nested within the selected folders, check 
the Include subfolders box at the bottom of the dialog.

 To expand the search to include compressed “ZIP” files, check 
the Include ZIP files box at the bottom of the dialog.

The preview pane shows a thumbnail image of each design present 
in the directory or directories you have selected. 

When you use the Browser, you can speed up your search by 
restricting it to folders where you know your designs are located.

To narrow the scope of the search, click the small plus + sign next to a 
folder to expand it. This will display the sub-folders it contains; you can 
then check only those sub-folders that contain the design files you want 
to browse.

If “Include subfolders” is checked, this may add a significant amount of 
time to the search, depending on how many files are in the folder or 
folders you have selected. If possible, it is better to narrow down your 
search first, in step 2), to the folder or folders that contain your 
designs.

Similarly, looking in ZIP files may increase the time needed to search 
for designs, so it is advisable to check this option only if you expect 
that the designs you need are in a “zipped” folder. 

If the search does seem to be taking too long, you can always press 
the Esc key to cancel it, and start a more limited search.



130 BES Blue
4 Do one of the following:

 To select a single design, click on the thumbnail image.

 To select a number of separate designs, click on each 
individually while holding down Ctrl.

 To select a series of designs, click the first thumbnail, then shift 
+ click on the final thumbnail in the range.

The selected files are highlighted.
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5 Do one of the following:

 To open the selected file or files in a new window, click the 
Open button. 

The selected design or designs open in your workspace; if 
multiple designs were opened, each will open in its own tab.

 To merge the selected file or files into the current design, click 
the Merge button.

The embroidery file (or files) will open.

Choosing the Default Recipe
You choose one of the pre-installed recipes through the New design 

dialog each time you open a new design. The NORMAL recipe is the 

default for new designs; however, you can set the default to a different 

recipe through the Preferences dialog box.

To open the Preferences dialog box, go to the View tab on the ribbon 

and click on the Preferences  button.
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The recipe you choose then becomes the default for all subsequent 

design files that you open. The recipes containing fabric settings are 

applied to all the lettering you create in that design.

Saving a Design
The Save As command lets you save an alternative version of the 
design with a different name, location, or file format. Save As is used 
when you want to keep your original design and create another design 
with slight modifications. The Save command saves the changes you 
make to the current design.

To save an alternative version of a design:

1 Do one of the following:

 Click the Accelerator button , and choose Save As  from 

the menu

 On the Quick Access Toolbar, choose the Save As tool.

You see the Save As dialog box.

2 In the Save in list, browse to the location you want to save your file.

3 In the File Name box, enter the file name for the design you want to 

save.

4 In the Save As type list, select the file type you want the design to 

be saved as.

5 Click Save.

To save changes to the current design:

• Do one of the following

 Click the Accelerator button , and choose Save  from 

the menu.

 On the Quick Access Toolbar, click the Save  button.

You can also change the recipe (style) of a design, or part of a design, 
after it has been created.

With the Select tool active, select part of the design (or Ctrl+A to select 
all of the design) and then right-click; from the context menu, chose 
Apply Style, and then select the desired recipe from the list.
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Using the Batch Converter
You can use the Batch Converter to convert files from one type (file 

extension) to another. This tool allows you to select one or more file 

extensions (e.g. *BRF, *.PES, etc.) in one design folder (the source 

folder), and convert them en masse into another file type in a second 

folder (the destination folder).

To batch convert files:

1 On the Tools tab, select the Batch Converter  icon.

You see the Batch Converter dialog.

If the design was created using the New Project  tool, it will be 

saved under the same name that you entered into the name field of the 

New Project dialog. If it was created using the New  tool, the design 

will be untitled, and you can enter a name for it in the Save as dialog 
when you save it.

Note that you can choose several different file types to convert from, 
you can only choose one file type to convert to.
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2 Click the browse  icon to the right of the Source field, and 

browse to the folder containing the files you want to convert.

You see a Browse for folder window. 

3 Select the source folder and click OK.

The folder path appears in the Source Folder field.

4 Click the browse  icon to the right of the Destination field, and 

browse to the folder containing the files you want to convert.

You see a Browse for folder window. 

5 Select the destination folder, and click OK.

The folder path appears in the Source Folder field.

6 In the Source Formats window, check the boxes of the file type (or 

types) that you want to convert.

7 In the Target formats window, check the box next to the file type 

you want to convert the files to.

8 Click Convert.

You see the Convert window, which shows the progress of the 
conversions in progress.

9 Click OK.

The convert dialog will close automatically.
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Selecting and Moving Parts of a 
Design

The Select Tool

The Select  tool allows you to select and modify individual design 

components, or groups of design components. Design components 

that have been selected using the Select tool can be moved, 

duplicated, deleted, resized and rotated in either direction.

The Select tool is also used to select a number of components in order 

to align them as you wish; for more information, see, “Aligning design 

components horizontally and vertically.”

The Select tool can be used for both text segments and design 

segments; however, to do more detailed editing of text segments, such 

as resizing, stretching, or rotating, you will want to select them with the 

appropriate text tool.

For more information on editing with these tools, see the 

corresponding sections for each tool under “Creating Lettering.”

To select one segment in the design:

1 From the Home tab, click the Select  tool.

2 Click the design component you want to select.

The active segment is enclosed in a selection box.

It is important to note that, whenever you open a design, all the 
components will be grouped by default. 
Therefore, if you want to use any of the following procedures to select 
individual segments of the embroidery design, you must first Ungroup 
the design. To do this, right-click on the design and choose Ungroup 
from the context menu.
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To select multiple components in the design:

1 On the Home tab, click the Select  tool.

2 Click a design component. Press Ctrl on your keyboard while you 

click each design component not already selected.

The active design components will be enclosed in a selection box 
with handles.

To select all components of the design:

1 Using the Select  tool, click in the workspace, and draw a box 

large enough to enclose all components of the design.

2 To select all the design components currently in the active window, 

do one of the following:

 Click on the small down arrow under the Select tool on the 
ribbon, and choose Select All.

 Press Ctrl + A on the keyboard.

To select segments using the Sequence View area:

1 On the Home tab, click the Select  tool.

2 In the Sequence View, select the group of segments which contains 

the desired segment or segments; if it is not already in expanded 

view, click the small plus sign next to the group in order to the list 

of individual segments in the group.
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3 To select one segment, click the segment from the list.
In the design workspace, the active segment is enclosed in a 
selection box with handles.

4 To select multiple segments within the Sequence View area, do any 
of the following:

 Click a segment. Press Ctrl on your keyboard while you click 
each segment not already selected.

 Click a segment at the start of your selection. Press Shift on 
your keyboard while you click the segment at the end of your 
selection. To extend the range of selected segments, press 
Shift again or Shift+Ctrl while you click any segment outside 
the range of segments already selected.

In the design workspace, the active segments are enclosed in a 
selection box with handles.

5 To edit or change the properties of the segments, do any of the 
following:

 In the design workspace, right-click the segment(s) and choose 
any of the options available in the edit menu.

 In the Sequence View area, right-click the segment(s) and 
choose any of the options available from the menu.

 In the Properties box, alter any property settings as required.

Copying, Cutting, and Pasting Design 
Components
You can use a variety of methods to copy design components in your 

designs. You can Copy or Cut, and Paste using tools on the Home tab, 

the right-click menu, or keyboard shortcuts. See the following 

procedures.

You can also copy and paste selections using the Power Copy tool; 

see the following section, “Copying segments using Power Copy.”

To copy to the clipboard:

1 Select one or more design components you want to copy.

2 To copy design components to the clipboard, do one of the 

following:

 In the Clipboard area on the Home tab, click on the Copy  

button.
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 In the design workspace, right-click on the selection and 
choose Copy from the menu.

 Press Ctrl + C.

The design components are copied to the clipboard.

3 To paste design components from the clipboard, do one of the 

following:

 In the Clipboard area on the Home tab, click on the Paste  

button.

 In the design workspace, right-click anywhere and choose 
Paste from the menu.

 Press Ctrl + V.

To cut to the clipboard:

1 Select one or more design components you want to cut.

2 To cut design components to the clipboard, do one of the following:

 In the Clipboard area on the Home tab, click on the Cut  

button.

 In the design workspace, right-click on the selection and 
choose Cut from the menu.

 Press Ctrl+X.

The design components are removed from their location.

3 To paste design components from the clipboard, do one of the 

following:

 In the Clipboard area on the Home tab, click on the Paste  

button.

 In the design workspace, right-click anywhere and choose 
Paste from the menu.

 Press Ctrl + V.

A quick way to Copy and Paste segment is to do the following: Select it, 
then press the Ctrl key and click. Drag the mouse to the desired 
location on your workspace, and then, release the mouse button to 
place the component.
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Copying segments using Power Copy
You can copy, rotate, and resize a text or design segment all in one 

step using Power Copy. When you are in Power Copy mode, just click 

and drag the mouse to draw your copy in any size, and any angle, that 

you want.

To use Power Copy:

1 Using the Select  tool, select the text or design segment.

2 Right-click, and choose Power Copy from the context menu.

Your mouse pointer changes into a cross hair.

3 Move the pointer to the location you want to place the copy. 

4 Click and hold; this creates the first point of a baseline.

5 To change the size of the copy, drag the pointer away from this 

point; length of this baseline determines by the overall size of the 

copy.

6 Choose the orientation of the copy by dragging the base line in the 

direction you want.

You see the outline of the segment you are copying.

7 Release the mouse button to place the copy.

A copy of the selection is placed in the new location.

8 The original selection that was copied will still be ‘loaded’ at this 

point; to place more copies, repeat steps 3–7.

You see the additional copies in the Design Workspace.
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9 When finished placing your copy or copies, right-click to exit the 

Power Copy tool.

Aligning Horizontally and Vertically
You can align lettering or design components horizontally or vertically 

using the Align tools on the Arrange tab.

Vertical alignment

Horizontal alignment
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To align design components:

1 Select the design components you want to align.

See “Selecting and Moving Parts of a Design.”

2 On the Arrange tab of the Ribbon, select the appropriate button 

from the following:

Using the Distribute Tools
The distribute tools evenly distribute three or more selected objects 

within a design. The selected items may be distributed in either the 

vertical or horizontal axis.

Align Left: Aligns all selected objects to the left-most item selected.

Align Right: Aligns all selected objects to the right-most item 
selected.

Align Top: Aligns all selected objects to the top-most item selected.

Align Bottom: Aligns all selected objects to the bottom-most item 
selected.

Vertical Center: Takes all selected objects and centers them in the 
selection box. The objects are moved so that they are centered top-
to-bottom with each other, but they are not moved left or right.

Horizontal Center: Takes all selected objects and centers them in 
the selection box. The objects are moved so that they are centered 
left-to-right with each other, but they are not moved up or down.

Center: Centers the selected objects in the current hoop.
If more than one object is selected, the entire group is moved 
together to the center of the hoop; the objects selected remain in the 
same position relative to each other as they had before being 
centered.

Important notes regarding the Distribute tools:
• These tools can only be applied if three or more objects are 

selected.
• When working with designs consisting of multiple objects, you 

must group them before distributing.
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To use the distribute tools:

1 Using the Select tool, select at least three objects in the 

workspace.

2 On the Arrange tab, choose one of the following:

  Distribute Horizontally : Spaces the selected objects 

evenly in the horizontal direction.

 Distribute Vertically : Spaces the selected objects evenly 

in the vertical direction.

The objects will be evenly distributed in the design workspace.

Moving Parts of a Design Manually
You can move the component parts of your design relative to each 

other by dragging them to another location.

To move a design component manually:

1 From the Home tab, click the Select  tool.

2 Click and drag the design component to its new location. 

As you drag, the status line displays the horizontal (dx) and vertical 
(dy) distance.

Resizing segments
Resizing a segment enlarges or reduces it horizontally or vertically, 

relative to the percentage you designate. You can manually resize 

segments in the workspace, or use the Transform tab settings 

available for finer control.

If the Transform tab is used to resize the selection, you have the 

option of resizing by absolute size, or a percentage of the segment’s 

original size.

To resize segments manually using design handles:

1 Select one or more segments.

The active segment(s) is enclosed in a selection box with handles.

2 Do one or more of the following to resize segment(s):
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 To resize by width, click and drag the design handles located 
on the left and right side of the selection box.

 To resize by height, click and drag the design handles located 
on the top and bottom sides of the selection box.

 To resize proportionally, click and drag the design handles 
located at the top or bottom corners of the selection box.

To resize segments using the Transform tab:

1 Select the segment or text with the Select tool.

The active segment is enclosed in a selection box with handles. 

2 In the Transform area of the Properties Panel, do one of the 

following:

 To resize by absolute (linear) values, check the Absolute 
checkbox; enter the desired width and height in the 
corresponding fields.

 To resize by percentage, check the Relative checkbox; enter 
the desired percentage change in the width and height in the 
corresponding fields.

3 Click Apply.

Converting to Stitch Segments
You can convert outline segments into stitch segments. Outline 

changes made to any part of the design will not affect segments, once 

they have been converted to stitch segments. If a segment has been 

converted to stitches, you cannot perform outline property changes, 

such as changing the fill or run style, or adding pull compensation or 

underlay. However, the converted segments may still be resized, 

rotated or have color changes applied to them.

To convert segments into stitch segments:

1 Select the segment you want converted into a stitch segment.

To maintain the proportions of an object while resizing it, select 
Maintain aspect ratio if not already selected.

Warning: Use caution when resizing or otherwise transforming 
segments that have been preserved as stitches; major editing of these 
segment is not advisable.
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2 Do one of the following:

 In the design window, right-click the segment and choose 
Preserve As Stitches from the edit menu.

 In the Sequence View area, right-click the segment and choose 
Preserve As Stitches from the menu.

Nudging Design Components
Nudging moves the selected design component or group of design 

components. Nudging is similar to dragging the design component but 

the distance that the design component moves is smaller. 

To nudge up:

• Use Ctrl + 

To nudge down:

• Use Ctrl + 

To nudge left:

• Use Ctrl + 

To nudge right:

• Use Ctrl + 

Deleting Design Components
Deleting a design component removes it from the design. The only 

way to retrieve a design component you delete is to use the Undo  

tool from the Quick Access tool bar immediately after you delete it.

To delete a design component:

1 Select the design component.

2 There are three ways to delete a design component:

 Right-click and select Delete from the shortcut menu.

 Press Delete on your keyboard.

 Choose the Delete command from the Home Tab on the ribbon.
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Rotating Design Components
Rotating a design component moves it around the center point of the 

selection.The rotate tools on the Arrange tab may be used to rotate 

Text or merged stitch designs through 90º increments. To rotate text 

through a smaller angle, you can rotate the selection using the frame 

handles, or by using the Rotate Angle  tool on the Arrange tab; the 

Rotate Angle tool allows you to type in an exact angle of rotation.

See “Rotating the Text Frame” in the section on Creating Text.

To rotate segments manually:

1 Select one or more segments you want to rotate.

The active segment(s) is enclosed in a selection box with handles.

2 Move your mouse over the blue rotation handle beside the top, 

right or the bottom left design handle.

You see the cursor change to a circular arrow.

3 Click and drag the rotation bead to adjust the box to the angle you 

want.

To rotate design components using the Transform tools:

1 Select one or more design components you want to rotate.

The active design component(s) is enclosed in a selection box.

2 From the Arrange tab on the ribbon, select one of the following:

You cannot use the Text tool to rotate merged segments, or text 
segments that have been combined with merged stitch segments.

The number of degrees of rotation is displayed on the status line in 
the bottom left corner of the workspace window.

Rotate Left: Rotates one or more selected objects to the left by 90º 
increments.

Rotate Right: Rotates one or more selected objects to the right by 
90º increments.

Rotate Angle: When clicked, this will open the Rotation dialog. In 
the dialog, enter the exact number of degrees of rotation you want 
to apply to the selection, then click OK.
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Removing Overlapping Stitches
When you merge two or more designs together, or create multiple 

designs with overlapping areas, you can easily remove those stitches 

that are overlapped. Do this by selecting the top segment, right-

clicking, and selecting “Remove Overlapped Stitches.” 

Note that “Removed Overlapped Stitches” will not be applicable to 

designs without outlines (that is, regular machine files) unless they 

have been converted to outlines. However, you can convert such files 

to outlines using the Merge tool or the Browser tool.

See “Merging Stitch Files” and “Opening Files from the Browser” 

This function also allows you to retain some of the overlap when per-

forming Remove Overlapping stitches, by setting an overlap distance. 

Leaving some overlap helps eliminate the gaps that can sometimes 

occur when all the overlap is removed.

To remove overlap:

1 Select the top segment that overlaps other segments or designs.

2 Right-click, and choose Remove Overlapped Stitches from the 

shortcut menu.

You see the Allowed overlap distance dialog.

3 To retain some overlap between the stitch segments, type the 
distance in the box, and click OK.

The overlapped portions of selected segments will be removed 
accordingly.

Remove overlap performance may vary due to the way the design has 
been digitized.

The default is set at 0.5 mm. This will prevent any gaps from occurring 
when stitching the design.
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Using the Line and Shape Tools
With the Line and Shape tools, you can draw and edit artwork to create 

new shapes in your designs.

Drawing Lines
You can use the Line tool to create artwork (that is, outlines without 

stitches) in designs. You can draw either straight or curved points. Use the 

Close Shape tool to convert an open shape to a closed shape. These 

artwork designs can then be converted into printable image files, using the 

ScanNCut tool.

For information on using ScanNCut tool, see “Special Design Tools—

ScanNCut.

To create lines with the Line Tool:

1 On the Tools tab, select the Line  tool.

2 Click in the design workspace to place points:

 To place a straight point, click in the design workspace.

 To place a curved point, press and hold Ctrl on your keyboard 
while clicking.

 To begin creating a straight line again, release Ctrl on your 
keyboard.

You see the curve previewed in the workspace as you place the 
anchor points.

3 To close the segment, do one of the following:

 On the Tools tab, click the Close Shape  tool.

 Press H on your keyboard.

4 Right-click to complete the segment.

Click on Apply Stitches to add a stitch type to the segment.

If you make mistakes as you draw, you can undo your last action by 
pressing Backspace on your keyboard; this will remove the points one 
at a time, in reverse order.
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Editing Artwork with the Edit Shape Tool

Use the Edit Shape  tool to add or delete anchor points (nodes) on 

an vector artwork segment (such as those created with the line tool) or 

embroidery segment that contains outline (e.g., a run, satin, or 

appliqué). When you select the segment, and then select the Edit 

Shape tool, the anchor points appear as blue squares along the outline 

of the shape.

Adding anchor points gives you finer control over the shape of the 

outline segment; when you delete anchor points you simplify the 

outline. 

You can also use this tool to move the anchor points, allowing you to 

modify the shape of an existing line or shape.

To add an anchor point:

1 Select a segment.

2 On the Tools tab, click the Edit Shape  tool. 

3 Right-click the location where you want to add an anchor point.

You see a context menu.

4 Choose Add Point from the shortcut menu.

The new point appears on the selected line.

To delete an anchor point:

1 Select a segment with the Select  tool.

2 On the Tools tab, click the Edit Shape  tool. 

3 Right-click the anchor point you want to delete.

You see a context menu.

4 Choose Delete Point from the shortcut menu.

The anchor point is removed from the selected line.

To change the shape of an existing artwork outline:

1 Select a segment with the Select  tool.

2 On the Tools tab, click the Edit Shape  tool. 

3 The anchor points appear on the segment, as small blue squares.

4 To re-shape the outline, do the following:
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 Click and drag on an anchor point to move it to the desired 
position.

 Release the mouse button.

5 Repeat step 4 for any other anchors, as required.

6 Click in an empty area of the workspace (or click on the Select tool) 

to de-select the Edit Shape tool.

The outline will take on the new shape.

Changing the Properties of an Anchor Point

Using the Edit Shape tool, you can change the properties of an anchor 

point. By default, when an anchor is placed, it will create straight point 

- which is to say, the angle of the lines on either side go straight to the 

adjacent anchor points. The point may be moved, but there are no 

direction lines that can be move to change the shape of the path.

However, when the Edit Shape tool is active, you can right-click on the 

anchor point and change the given straight point to a smooth or cusp 

point, which have direction lines that you can click and drag to change 

the corner shape.

To change anchor point properties:

1 Select a segment with the Select  tool.

2 On the Tools tab, click the Edit Shape  tool. 

The anchor points appear on the segment.

3 Right-click an anchor point.

You see a context menu.

4 From the context menu, select one of the following:

 Cusp: Allows editing (direction and length) of the direction 
lines on either side of the anchor point; permits yo u to make a 
sharp (or shallow) bend to a curve.

 Smooth: Constrains the angle of the direction lines to 180º and 
allows you to vary the length of the direction line side of the 
anchor point. Creates a smooth transition on either side of the 
point. 
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The original artwork (Line Tool) segment.

The original segment with the point of the right triangle converted to cusp, 
and the direction lines adjusted to create a sharp peak

The same segment with the point of the right triangle converted to smooth. 
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Creating Holes in an Artwork Segment

You can use the Edit Shape tool to insert holes (unfilled areas) in filled 

artwork segments. For example, you can use this tool to create holes 

in artwork created using the ScanNCut tool.

To create holes in an artwork segment:

1 Select an artwork shape.

2 From the Tools tab, select the Edit Shape  tool.

3 Hover over any anchor point and right-click.

You see a context menu.

4 From the menu, select Add Hole.

The cursor changes to a small cross symbol.

5 Left-click inside the segment to place the anchor points in the 

shape of the hole you want to create.

6 On the Tools tab, select the Close Shape  tool.

7 Right-click twice in the design workspace to complete the 

segment.

You see the Fill segment with the hole (or holes) created.

Converting to Appliqué

The Convert to Appliqué  tool converts a selected outline segment 

into an appliqué, complete with positioning, tack down, and border 

stitches. This tool may be applied to any segment containing outlines 

(e.g. *.BRF file). It will also convert artwork segments, such as 

imported *.FCM files or artwork that has been created with the Line 

tool; see “Using the Line and Shape Tools.”

When a segment has been converted, it will be assigned the default 

appliqué properties; these properties may be adjusted (e.g. Appliqué 

border, stitch length, offsets) in the Properties Panel.

If you want to remove a hole, select one of its anchor points, right-click, 
and select Remove Holes from the context menu. The selected hole will 
be filled in again.
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To convert artwork to appliqué:

1 Select the outline segment (or segments) that you want to convert.

The original segment, consisting of two complex fill segments, prior to conversion.

2 On the Tools tab, click the Convert to Appliqué  tool.

The segment(s) will be converted to appliqué.

The design after conversion to appliqué, thread color change, and adding fabric 
backgrounds.

3 Adjust the appliqué properties in the properties panel.

 See “Embroidery Segment Properties—Appliqué Properties.”

4 Save the file.
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Embroidery Segment Properties
Segment that have been converted to Run, Appliqué and Decorative 

Fill segments will be given a set of default properties when first 

generated. These default properties will be suitable in many situations, 

but may need to be adjusted in the Properties panel. 

Run Properties
To adjust the properties of Run stitches, first select the segment using 

the select tool. The properties of run segments that can adjusted are 

the following.

• Type: Determines the type of run stitch – choose one of the 

following.

• Single run: A simple forward-moving stitch.

• Double run: A stitch that goes from the beginning of the 

segment to the end and back again.

• Bean: Also known as three-ply stitch, this is stitch which is 

sewn back and forth (forward, back, and forward again) in the 

same place before moving on to the next stitch. 

• Stitch length: Length of the stitches in the run segment.

• Bean repeats: Applies only when Bean has been selected in the 

Type field. This setting determines how many times the bean 

stitches are repeat each time. Select either 3 or 5 repeats.

Appliqué Properties
After you select the Appliqué stitch type, you can adjust any of the 

default settings. There are four different types of Appliqué border 

available:

• Satin

• Blanket

• Motif

• Run
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The adjustable settings that you will see in the properties box will 

depend on which border type you select (settings that are not 

applicable will be grayed out). The following procedures set out how to 

adjust settings for each type of s

To adjust satin border settings:

1 Select the Appliqué segment.

2 In the Properties panel, click the down-arrow to the right of the 

Appliqué type field.

You see the list of Appliqué border options.

3 From the drop-down list, select Satin.

The Appliqué border of the selected segment will change to a satin 
segment.

4 Adjust one or more of the following settings:

 In the Stitch length field, enter the stitch length of the 
positioning and tack down run stitches.

 In the Width field, enter the desired width of the satin border.

 In the Density field, enter the density of the satin border.

 In the Inset %  field, set the percentage that the satin stitch 
border will be inset relative to the original outline. This setting 
determines by how much the satin stitches overlap the 
Appliqué fabric.

 In the Placement Offset field, enter the displacement of the 
placement stitches from the segment outline. The default offset 
is 0 mm, which means that the placement stitches will run 
exactly along the segment outline.

 In the Tackdown Offset field, enter the displacement of the 
tackdown stitches from the outline. The default offset is -0.5 
mm, which means that the tackdown stitches will be placed 0.5 
mm inside the segment outline.

 (Optional) In the fabric field, click Select to open the Fabric 
dialog to display a preview image of a fabric pattern within the 
Appliqué.

5 Click Apply.

For Appliqué with a satin border, the default setting is 50%; effectively, 
this means that the satin stitches will be half on the Appliqué fabric, and 
half on the underlaying fabric.
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To adjust blanket settings:

1 Select the Appliqué segment.

2 In the Properties panel, click the down-arrow to the right of the 

Appliqué type field.

You see the list of Appliqué border options.

3 From the drop-down list, select Blanket.

4 Adjust one or more of the following settings:

 In the Stitch Length field, enter the stitch length of the 
positioning and tack down run stitches.

 In the Width field, enter the width of the Blanket stitching.

 In the Blanket density field, enter the spacing of the stitches.

 In the Placement Offset field, enter the displacement of the 
placement stitches from the segment outline (in mm.). The 
default is 0 mm, which means that the placement stitches will 
run exactly along the segment outline.

 In the Tackdown Offset field, enter the displacement of the 
tackdown stitches from the outline (in mm.). The default 
tackdown offset is -0.5 mm, which means that the tackdown 
stitches will be placed 0.5 mm inside the outline.

 (Optional) Click in the Fabric field to show a preview image of a 
fabric inside the Appliqué.

5 Click Apply.

You see the segment altered accordingly.

To adjust Motif border settings:

1 Select the Appliqué segment.

2 In the Properties panel, click the down-arrow to the right of the 

Appliqué type field.

You see the list of Appliqué border options.

3 From the Appliqué type list, select Motif.

4 Adjust one or more of the following settings:

 Stitch Length: sets the stitch length of the positioning and tack 
down run stitches.

 In the Inset field, set the percentage that the motif stitch border 
will be inset relative to the outline of the original Appliqué 
segment. This setting determines by how much the motif 
stitches overlap the Appliqué fabric.
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 In the Motif field, click the down-arrow to select a pattern from 
the drop-down list of installed motifs.

 In the Motif Pattern Size field, adjust the size of the repeated 
unit in the motif pattern.

 In the Motif Stitch Length field, enter the stitch length for the 
motif border stitches.

 (Optional) Click in the Fabric field to show a preview image of a 
fabric inside the Appliqué.

5 Click Apply.

The Appliqué segment will be adjusted accordingly.

To adjust Run settings:

1 Select the Appliqué segment.

2 In the Properties panel, click the down-arrow to the right of the 

Appliqué type field.

You see the list of Appliqué border options.

3 From the Appliqué type list, select Run.

4 Adjust one or more of the following settings:

 Stitch length: Sets the stitch length of the positioning, tack 
down, and border run stitches.

Note that setting is independent of the stitch length for the positioning 
and tackdown stitches (set previously).
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  From the Run type field, select one of the follow run styles for 
the border stitches (does not apply to the placement or 
tackdown run stitches):

 Run

 Double run

 Bean

 In the Placement Offset field, enter the displacement of the 
placement stitches from the segment outline (in mm.). The 
default is 0 mm, which means that the placement stitches will 
run exactly along the segment outline.

 In the Tackdown Offset field, enter the displacement of the 
tackdown stitches from the outline (in mm.). The default 
tackdown offset is -0.5 mm, which means that the tackdown 
stitches will be placed 0.5 mm inside the outline.

 (Optional) Click in the Fabric field to show a preview image of a 
fabric inside the Appliqué.

5 Click Apply.

The Appliqué segment will be adjusted accordingly.

Adding a Fabric Background to an 
Appliqué Segment
You can now specify a fabric background to display within the border. 

You can select either from a list of fabric images provided, or import 

your own image file to use as a background.

To display a fabric background in an Appliqué segment:

1 Select the Appliqué segment.

2 Open the properties field and select the Appliqué tab.

3 Click the down arrow next to the Appliqué Fabric list to see the 

available fabrics, and choose one from the list.

4 Click Apply.

The selected fabric image appears within the Appliqué border.

The fabric image you apply in the Properties field will also be visible 
in the print-out of the design.
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To import an image for an Appliqué background:

1 Select the Appliqué segment.

2 In the properties panel, in the Fabric field, click the Select button.

3 You see the Fabrics Dialog.

4 On the dialog, select Add...

The Import Fabric dialog will open.

5 Browse to the location of the image you wish to use as a fabric 

background image.

6 Select this image and click Open.

The image appears within the Appliqué border, and it is added to the 
fabrics in the dialog for later use.

Decorative Fill Properties
Decorative fill segments consist of an area of Pattern fill, enclosed 

within a steil border. The follow procedure details the properties that 

can be adjusted for this type of segment.

To adjust Decorative Fill properties:

1 Select the Decorative fill segment.

You can also scan your own fabrics as images for use in your design 
projects. For best results, use a resolution of 300 dpi. A 1 in. × 1 in. 
piece of fabric should be sufficient for your sample. 
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2 In the Fill area of the Properties panel, adjust the following 

properties:

 Pattern: Click the drop-down list to select the pattern of fill 
stitches; the software includes a wide variety of patterns to 
choose from.

 Pattern Size: Sets the size (in mm) of the individual repeated 
units within a the pattern fill.

 Stitch length: Sets the length (in mm) for the pattern fill 
stitches.

 Angle: Click the drop-down list to choose the angle of the 
pattern fill rows (zero degrees = horizontal).

3 In the Steil area of the Properties panel, adjust the following 

settings:

 Width: Sets the width of the steil border.

 Density: Sets the density of the steil border.

4 Click Apply to apply the changes.

The Decorative Fill segment will change accordingly.
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Working with the Color Palette
In BES Blue, you can change the color of any segment of your design, 

whether it be a lettering or a merged stitch file. If you can select it, you 

can change its color.

The Color Palette, which is located along the top edge of the design 

space, shows you the thread colors that are available in the thread 

chart that is currently selected. 

Below the Color Palette you see the Design Palette, which displays the 

list of colors currently being used in the design. In the Design Palette, 

the individual colors have a number superimposed on them, which 

identifies the corresponding needle.

Selecting a Thread Chart
BES Blue comes with a large number of the most popular 

manufacturers’ thread charts already loaded. You are able to choose 

from amongst these charts by clicking on the Thread Chart button , 

which is on the left end of the Color Palette. Clicking this button will 

display the whole list of thread charts as a drop-down list. Click on the 

one that you want, and those thread colors will be loaded into the 

Color Palette.

Searching for a Specific Color

The Find button , located near the left end of the thread palette, 

allows you to search for a particular thread in the palette, if you know 

the name or thread number.

To search for a thread color: 

1 Click the Find  button. 

You see the Thread Color Search dialog.
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2 Type in all or part of the name or number of the thread.

3 When you have found the color you want, click on it to select it.

4 Click the Find button.

The color you were looking for will now be the selected color in the 
palette.

Changing a Thread Color
BES Blue allows you to adjust the colors of the lettering you create, or 

indeed any segment of the design, by using the Color Palette; you do 

this by choosing thread objects in the Color Palette.

To change thread colors:

1 Do one of the following.

 Select a segment in the workspace with the Select tool or one 
of the text tools.

 In the Sequence view, click on one of the segments.

2 In the Color Palette or Design Palette, click the color field with the 

thread color you want to use.

If you only know part of the thread name, and there is more than 
one possible match for that partial name, the search dialog will 
present you with a number of choices (as in the example below).

When changing the color of a lettering segment, you can select it with 
either the Text tool or the Select tool; however, other types of segments 
(such as those imported with the Merge tool) must be selected with the 
Select tool.

If you hover over a color square on the palette, the thread type 
and number will show beside the mouse pointer.
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Using the Thread Palette Creator
The Thread Palette Creator allows you to create your own custom 

thread palettes for use in your designs. Use this tool to build your own 

palette by importing thread colors from any of the thread palettes 

already loaded in BES Blue, or add your own colors from the RGB 

color wheel.

Creating and Saving a Custom Palette

To create a new color palette:

1 From the Tools tab, select the Thread Palette Creator .

The Thread Palette Creator dialog opens.

2 In the properties area, type a name for the new palette.

3 Add colors to the new palette by using the Import or Add Color 

buttons; see “Adding New Colors to a Custom Palette”.

4 When you have added all the colors you wish to your palette, click 

the Save button on the Thread Palette Creator dialog.

You see a confirmation dialog.

You cannot modify any of the color palettes that come installed with 
the software.
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5 Click Yes.

Your new custom palette will be added to the list of palettes.

6 If you wish to create another custom palette, click the New button, 

and repeat steps 2-6.

7 Click Exit to close the dialog.

Importing Colors into a Custom Palette

To Import Colors into a custom palette:

1 Create a new palette, or open an existing palette.

2 In the Color Palette Creator dialog, click the Import button.

You see the Import Color dialog.

3 Choose a Color Palette name from the list (if applicable).
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4 Choose the color you want from the palette.

5 Click Import.

The color is added to your custom palette.

6 Repeat steps 3–5 until you have added all the colors you want.

7 In the Import Color dialog, click Exit.

8 In the Color Palette Creator dialog, save the custom palette, and 

then click Exit to close the dialog.

Adding New Colors to a Custom Palette

To add new colors to a custom palette:

1 Create a new palette, or open an existing palette.

2 Click on the Add Color button.

The Color area of the dialog becomes active.

The Color area of the Thread Palette Creator dialog box.The color is chosen by 
typing in numbers on the boxes on the left, or by adjusting the color wheel and gray-
scale slider. The small square on the color wheel indicates the current hue/
saturation, and the gray-scale slider indicates the current luminance. The box in the 
upper-right shows the resulting color.

If you already know the name or numeric code of the color you wish to 
add, click on the “?” button on the bottom-left of the dialog. This will 
open the Find Color dialog; type the name or code into this dialog, and 
it will select that color in the palette for you.
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3 In the Color Name field, type a name for the new color.

4 In the Code field, enter a code for the color.

5 In the Color area, do one of the following:

 If you already know the RGB profile of the thread color you 
wish to add, type it in the boxes.

 To select the hue and saturation of the color manually, click and 
drag the indicator in the color wheel, and select the luminance 
(lightness/darkness) of the color by moving the slider (to the 
right of the color wheel) up and down.

 You see a preview of the color you have created in a small 
window on the upper-right of the dialog box.

6 To add another color, repeat steps 2-5.

7 When you have finished adding new colors to the custom palette, 

click Save to save your changes.

8 Click Exit to close the Color Palette Creator dialog.

Garment Templates
Garment Templates is a feature that allows you to see how your 

embroidery design will look in the context of an actual garment, 

without having to sew it out. In this feature, you choose a graphic 

representation of a garment from a list, and then select a background 

for it – you can choose either a solid color for this, or one of a number 

of fabric patterns.

You can incorporate text segments and/or designs into the Garment 

Template, and save it as a *.BRF file. When you re-open this file, both 

the design and garment information (e.g., fabric or color and size) will 

be retained.

To use Garment Template:

1 Create a new design, or open an existing file

2 Click the Garment Template  icon from the View tool bar.

You see the Garment Template dialog.



166 BES Blue
3 From the garment drop-down list, choose a garment template.

4 To select the background of the garment, do one of the following: 

 To choose a solid color.

 Click the color chip next to the Garment field.

You see an array of color swatches.

 Click on the “swatch” of the desired color.

The Garment color will change to the selected color.

 To choose a fabric background.

 Click the Select... button.

You see the Fabrics dialog, which shows thumbnail images of the 
fabric patterns available.

If you want to select a different color for the garment template, click on 
the More Colors button at the bottom of the given array of color 
swatches. This will open up the Color dialog, where you can choose 
any RBG color available from the palette.
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 Choose a fabric from the list.

 The pattern of the selected fabric will appear in the workspace.

5 (Optional) Change the height and/or width of the garment template. 

Do one of the following:

 Type a value into the Height or Width boxes.

 Enter a percentage change in either of the boxes that have the 
% symbol following them.

6 Click Okay.

The garment appears in your workspace.

The “Keep aspect ratio” box is checked by default; this ensures that 
the height and width stay proportional to each other as you change the 
value of one or the other. To change the height without changing the 
width, or vice versa, uncheck this box.

Once the garment is on screen, you can select it and rotate by clicking 
and dragging on the blue circles around the handles.
You can also resize the garment template manually on screen, by 
clicking and dragging the black square handles at the corners of the 
selection frame.
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Distorting Segments
Distortion, also called morphing, takes a set of stitches and moves 

them all around in a pattern. It distorts the design. Distortion works 

with working files (*.BRF) and stitch files or specified stitch segments.

BES Blue allows you to choose from several distortion effects for your 

designs. These effects allow you to adjust them. The adjustments 

available are Frequency, Amplitude, Angle, Radius and Scale. As you 

manipulate the controls for these effects, the result is displayed in a 

preview inside the Distortion dialog.

To distort segments:

1 Open an existing design.

2 Select one or more segments you want to distort.

3 From the Arrange tab of the Ribbon, select the Distort tool.

The Distort dialog appears with the selected segments displayed in 
the preview window.

4 In the Style area, select the distortion style you want.

You see this style applied to your segments in the preview window.

5 Adjust any of the distortion controls accordingly.

6 Click OK.

You see selected segments altered accordingly.

Distortion Controls: Frequency

The Wave and ZigZag distortions add a series of ‘ripples’ to the 

selected objects. The number of the ripples is controlled by the 

Frequency setting. You can experiment with the slider to see different 

numbers of ‘ripples’ in the preview panel of the Distortion dialog. The 

graphic below shows an example of ZigZag distortion. 

The effects of the different types of distortion are discussed separately, 
each in its own section, following the procedure below. 

You can distort all types of segments, including the various text 
segments and merged stitch segments.
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Distortion Controls: Amplitude

Going back to the ‘ripples’ concept, the amplitude is the height of the 

ripples. Here is an example ZigZag, but with an increased amplitude 

(the distortion frequency has been reduced for clarity):
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Distortion Controls: Angle

The Twirl effect uses an angle setting to determine how much ‘twist’ 

the design will be given.

Distortion Controls: Radius
The Pinch effect takes the middle of the design and stretches it so that 

it looks like a ball. The radius of this ball is controlled by the radius 

setting. Here is a pinch with a large radius:
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Distortion Controls: Scale
The scale is also used by the Pinch effect. It controls how much to 

expand the ‘ball’. The previous picture shows a low scale. The picture 

below is an example of a high scale:

Adding Basting Stitches
You can create a series of stitches that will baste a rectangular outline 

around the edge of a design. The stitches start at the top left corner of 

the design; these initial stitches are just jumps and do not sew. Then, a 

basting run stitch is sewn around the outer edge in a rectangle (close 

to the inside edge of the hoop) until complete. The next color is then 

the starting color of the design.

The basting stitches also help you to see that your hooping is lined up 

correct and straight, a feature that really helps where text is concerned 

as every error stands out clearly.

Basting Stitch settings

There is a setting in the Program Preferences window that allows you 

to adjust auto basting settings. On the Preferences tab, select 

Program Preferences , and click the Auto Baste tab.
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On the Auto Baste tab, you will find the following useful settings: 

• An optional ’crosshair’ can be added in the baste to allow easier 

centering of designs on the fabric (this setting will be on by 

default).

• The stitch length can be adjusted to make a tighter or looser 

basting stitch. 

• The basting stitches segment may be offset from the actual design. 

You can adjust the “Baste past outer edge of design” slider to set 

this value, from 0-10 mm. 

To add basting stitches to designs:

1 Open an existing design.

2 On the Home tab, in the Text section, click the Auto Baste  tool.

The basting stitches appear around your design.
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Sequencing Segments
Using the Sequence View, you can alter the sequence of segments in 

your designs. You can move them up, down, to the beginning of the 

sewing order, or to the end. You can also use this view to move a 

segment to the nearest layer (up or down) of the same thread color.

Sequencing Segments
The sequence of the segments is the order in which they are 

embroidered. The sequence is important because you want segments 

that are near to each other to sew one after the other. This reduces 

jump stitches and the need to trim them later.

For example, you can have three objects, all of which start on the left 

and end on the right. Object 3 is in between object 1 and object 2. This 

might not be optimal for jump stitches, and the machine will take 

longer to embroider the design in this sequence, compared to if the 

segments were properly sequenced. 

To sequence segments:

1 Select one or more segments you want to resequence.

2 Do any of the following:

 In the design workspace or Sequence View area, click and drag 
the segment(s) to the location you want.

 In the design workspace, right-click the segment(s) and choose 
Move–First, Move–Last, Move–Up, Move–Down, Move–Prev 
Match or Move–Next Match.

 In the Sequence View area, right-click the segment(s) in the list 
and choose Move–First, Move–Last, Move–Up, Move–Down, 
Move–Prev Match or Move–Next Match.

The Move—Prev Match and Move—Next Match commands 
automatically move segment(s) to the previous or next segment group 
that has the same thread color.
For more details, see “Moving a Segment to the nearest Matching 
Color Group.”
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Moving a Segment Forward or Backward
Use the Move Up commands to move the selected segment closer to 

the beginning of the design. Conversely, the Move Down command is 

used to move the selected segment closer to the end of the design.

A simple design of three segments (the letters on the left), plus the sequence view of 
the design. The image above shows the original design, and the one below shows it 
after a Move Up command. In this case, the Move Up command was used to change 
the sewing order so that, instead of jumping to the bottom letter and then going back 
to the middle (A - C - B) the letters sew in order from top to bottom (A - B - C).

To move a segment forward:

1 Select the segment or segments.

2 Do one of the following:

 In the design workspace, right-click the segment(s) and choose 
Move—Up.
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 In the Sequence View area, right-click the segment(s) in the list 
and choose Move—Up.

The segment is moved one position forward in the sewing order. 
This change is reflected in its position in sequence view.

To move a segment backward:

1 Select the segment(s).

2 Do one of the following:

 In the design workspace, right-click the segment(s) and choose 
Move—Down.

 In the Sequence View area, right-click the segment(s) in the list 
and choose Move—Down.

The segment is moved one position backward in the sewing order. 
This change is reflected in its position in sequence view.

Inserting Segments Earlier in the 
Segment Sequence
You can add segments earlier in your design’s segment sequence and 

change the order segments are sewn.

To insert segments before the insertion point:

1 Select and cut, or copy, the segment.

2 In the design workspace or Sequence View area, click where you 

want to insert the segment.

3 Do one of the following:

 Choose Insert  from the Home tab on the ribbon.

 Right-click and choose Insert from the context menu.

The selection is inserted before the insertion point.
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Moving a Segment to the Start or End of 
the Design
Use the Move–First command to make the selected segment the first 

one to be stitched. When a design is sewn, the first segment sewn is 

usually "on the bottom" or in the "back" of the design. Use the Move–

Last command to make the selected segment the last one to be 

stitched. When a design is sewn, the last segment sewn is usually "on 

top" or in the "front" of the design.

To move a segment to the start of a design:

1 Select the segment(s) you want to move to the start of your design.

2 Do one of the following:

 In the design workspace, right-click the segment(s) and choose 
Move—First.

 In the Sequence View area, right-click the segment(s) in the list 
and choose Move—First. 

In the left image, the green letter A is originally the third segment in the sewing 
order; after selecting Move–First, it will be behind all the other segments, as shown 
on the right.

To move a segment to the end of a design:

1 Select the segment(s) you want to move to the end of your design.

2 Do one of the following:

 In the design workspace, right-click the segment(s) and choose 
Move—Last.

 In the Sequence View area, right-click the segment(s) in the list 
and choose Move—Last.
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In the left image, the red letter D is originally the design’s the second segment; after 
Selecting Move–Last, it will be on top of all other segments, as shown on the right.

Moving a Segment to the nearest 
Matching Color Group
BES Blue allows you to automatically move a segment to the previous 

or next segment group or layer that has the same thread color.

To move a segment to the previous thread color layer:

1 Select the segment(s) you want to move.

2 Do one of the following:

 In the design workspace, right-click the segment(s) and choose 
Move—Prev Match.

 In the Sequence View area, right-click the segment(s) in the list 
and choose Move—Prev Match. 
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The selected segment appears in the sequence below the previous 
group with the same thread color.
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To move a segment to the next thread color layer:

1 Select the segment(s) you want to move.

2 Do one of the following:

 In the design workspace, right-click the segment(s) and choose 
Move—Next Match.

 In the Sequence View area, right-click the segment(s) in the list 
and choose Move—Next Match. 

The selected segment appears in the sequence below the previous 
group with the same thread color.
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Color Sort

The Color Sort  tool enables you to rebuild a design that has the 

same color used more than once into a design with a minimum of color 

stops. The color sort tool applies to both embroidery and artwork 

segments.

The Color Sort tool analyzes a design to see if any colors are 

repeated. It then looks to see if any of those repeated colors can be 

combined into a single layer. If not, the color layers are left intact.

Color sort layer overlap setting

There is a setting that allows you to adjust the sensitivity to the 

layering. This is found on the View tab – select the Program 

Preferences  button, then the Color Sort tab.

Certain file types have color limitations that make color sort 
unadvisable. In these cases, the designer ran out of colors and 
had to re-use a color to complete the design. Also, some designs 
use color stops to indicate an appliqué or a trim. Not all file types 
have these functions built-in. In these cases, Color Sort should 
be used with care.
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This adjustment allows some portion of the stitches to be overlapped 

in order to allow a color change to be removed. The overlap setting is 

expressed as a percentage; 0% means that no stitches will be overlaid 

in the process of preforming the color sort, while 100% means the file 

will be compressed regardless of layering. The default is 5%, which 

seems to work very well for most designs.

To use the Color Sort tool:

1 Open an existing design.

2 Select the segments in the design that you want to sort by color; to 

sort the whole design, press Ctrl + A on the keyboard to select all 

segments.

3 On the Home tab, click the Color Sort  tool.

A dialog appears, indicating the number of colors reduced in your 
design. 

4 Click OK.

Adding Design Notes
You can now add written notations right into the BES Blue workspace, 

using the Add Notes  tool. These notations will be saved when you 

save the file in outline format (*.BRF), and can be used to save (and 

pass on) information about the design.

If you save the file in a stitch format (such as *.PES), the note 
will not be saved along with the file.
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Note that these notes are not actually part of the design - neither 

artwork nor stitches – so they will not effect the sewing or print 

preview. 

To add Design notes:

1 Open a working file format (*.BRF) design, or create a new design.

2 On the Home tab, click the Add Notes  tool.

3 Click in the Design Workspace where you want to place the note.

A new dialog pops up in front of the Workspace.

4 Type the note into the dialog. Click OK.

The note appears in the workspace in the place you originally 
clicked. 

5 If you need to change the content of the note, do the following:

 Open the Properties Panel.

 When the properties panel opens, you will see a tab displaying 
the Note text. On this tab, you will be able to edit the contents 
of the note. You can also rotate it, if necessary, to fit into the 
design better.

 To move the note, choose the Select tool and then select the 
note. The note can be easily moved to a new location.
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Viewing Hidden Segments in 
Ghost Mode
The Ghost  tool allows you to see segments of the design that are 

hidden. When you turn on Ghost Mode, you will see the hidden 

segments of the design as an off-white color. This allows you to see 

where the rest of the design is, but not have confusion as to which 

parts of the design are selected for editing.

To apply Ghost Mode:

1 Open an existing design file.

2 Open the Sequence view.

3 In the Sequence View, select the segment you want to edit - that is, 

the segment that you do not want to have “ghosted.”

4 Right-click on the segment and choose Hide others from the menu.

5 On the View tab, click the Ghost  icon.

The segments of the design that were not selected are now hidden. 
You can work on the selected area.
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Printing Designs
You can make print-outs of your designs in BES Blue. These print-outs 

not only give you a preview of what the design will look like, but they 

have a lot of other information, including the number of stitches in the 

design and its overall size. Also, by selecting the “Print Color Analysis” 

option in the Print settings dialog, you can print the color, name, and 

length of each thread used.

Previewing a Design before Printing
You can preview a worksheet on the screen before sending it to the 

printer.

To preview a design:

1 Click the Accelerator  button and select the Print  tool and 

then Print Preview  from the list.

2 To zoom in and out of the previewed worksheet, do the following:

 To zoom in on the worksheet, click Zoom In and scroll to view 
specific parts of the design.

 To zoom out on the worksheet, click Zoom Out and scroll to 
view specific parts of the design.

3 To close print preview and return to the design window, click Close.

Printing Design Worksheets

You can print a design, without previewing it. Click the Accelerator  

button, select Print  and then click on Print Setup . This button 

opens your computer’s Print dialog, where you can choose printer 

options such as how many copies you want to print.

You can also print worksheets of your design immediately, without 

previewing the design or changing printer options. To do this, choose 

the Direct Print  tool.
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To print a worksheet for your design:

1 Do one of the following:

 On the Accelerator Menu, select Print—Print Setup.

 Press Ctrl+P on the keyboard. 

You see the Print Setup dialog.

2 Make any required changes to the print settings.

3 Click OK to send the file to the printer.

Changing the Print Settings
You can customize print settings for your embroidery designs. BES 

Blue allows you to adjust the image and worksheet information 

displayed in design printouts.

To change a design’s print settings:

1 Click the Accelerator  button, select the Print  tool and then 

select Print Preview  from the menu.

You see the print preview window, displaying your design.
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2 On the preview’s toolbar, click Settings.

You see the Print Settings dialog.

3 In the Margins area, enter the margin sizes you want for your 

design worksheet.

4 Select Print Actual Size to have your design print in its actual size.

5 Select Print In One Page to print a single worksheet page.

6 Select Print Company Name to have the name of your company 

name printed on your design worksheet. 

Enter your company name in the box below.

7 To prevent jump stitches from showing on your print preview, check 

the Remove Jump Stitches box.

8 Select Print Color Analysis to print an expanded thread sequence 

view that includes a view of the colors used, the color sequence, 

and the thread consumption for each color.

9 Select Show Crosshair to print a set of crosshairs superimposed on 

the design print-out. 

10 Click OK to save the changes to print settings.

11 Click Print to print out the print preview, of Close to exit without 

printing.

If Print Color Analysis is selected along with Print In One Page, your 
print out will display a basic thread sequence view. This includes a 
simplified view of the colors used, the color sequence and the thread 
consumption.



This section covers special design tools that can be used to enhance 

your lettering designs. These include tools to add extra embroidery to 

embellish the lettering (such as accents, borders, frames, etc.) and 

tools that arrange designs into patterns (paths, circles, and corners).

You can also fill a given shape with a randomized selection of text 

segments, using the new Word Collage feature.

The ScanNCut tool allows you to convert Appliqué Designs into a 

printable image, so that they can be scanned into a fabric cutting 

machine, such as Brother ScanNCut.

Topics covered in this chapter:

• Merging Designs

• The Add Designs tool

• Arrange tools: Path, Corner, Circle, and Scatter Design

• Using the Word Collage tool 

• Using the ScanNCut feature

CHAPTER 5:

Special Design Tools
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Merging Design Files
 You can merge multiple design files into an active design window. 

Click on Merge  to import an existing design file (or files) and add 

them to your design. You can merge design files from a variety of 

formats.

To merge a design:

1 Open an existing design, or create a new design.

2 Click the Accelerator  button and select the Merge  tool.

You see the Merge Design File dialog.

3 In the Look in list, browse to the location of the file you want to 

merge.

4 In the Files of type list, select a design file type for the design you 

want to merge.

5 In the File Name box, select the design file that you want to merge 

onto the current open design workspace.

6 To view a preview of the selected design, select Preview, if not 

already selected.
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7 (Optional) Check the Convert to Outlines box.

If this option is selected, the design’s stitch segments will be 

converted to outlines, allowing you to select the segments 

individually in the Sequence View. Once you have converted, you 

can save the file as a *.BRF.

A preview image of the selected design appears in the small window 
on the right-hand side of the dialog.

8 Click Open.

The merged design file appears in the design workspace.

You can now select and move the stitch file to place it in the desired 
position relative to your lettering.
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Add Design

The Add Design  feature allows you to embellish the lettering in 

your design with decorative embroidery. You can choose from among a 

wide variety of embroidery accents, borders, frames, appliqué shapes, 

text connectors and place them in your design using only the mouse 

buttons. These designs come pre-loaded with your software.

To use the Add Designs tool:

1 In the Home tab of the Ribbon, click on the Add Design  tool. 

A pop-up window opens in front of the workspace, displaying 
thumbnails of the available decor designs.

2 From the Folder drop-down list, choose one of the following 

categories:

 Accents

 Appliqué Shapes

When an embroidery design is imported using the Add Design tool, the 
design will retain its own recipe, which may be different from the one 
used for the design it is being imported into.

However, you can change the recipe of the imported design, if 
necessary, by selecting it, right-clicking, and then selecting Apply 
Style... from the context menu that appears.
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 Backgrounds

 Borders

 Connectors

 Designs

 Frames

 Monogram Designer Decors

 Monogram Designer Frames

 Split Designs

The list of thumbnails in the Add Designs window changes 
depending on the category selected.

3 In the window, click on the design you want to import.

The Add Design window closes; your cursor changes to a small 
cross, indicating that the Add Design tool is active.

4 Place the mouse pointer, at the position you would like the Add 

Design to begin.

Connectors, when used between individual letters, can be used 
to create ‘custom’ monograms.

To see a design in more detail before selecting it, you can “hover over” 
the thumbnail; a larger image of the design will pop up.
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5 Click and drag the mouse; as you drag, note that the Add Design 

appears in outline in your workspace. This outline indicates the 

size and orientation of the Add Design embroidery, before it is 

actually generated in your design.

6 To finish placing the Add Design segment, release the mouse 

button.

7 To adjust the size and orientation of the Add Design segment after 

it is placed, select it with the Select  tool, and use the handles to 

resize or rotate it.

You can also insert a design quickly by just following steps 1-4 above, 
and then double-clicking in the workspace. This will add the selected 
design at the default size.
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Your accent, border, frame, or appliqué appears in your design.
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Monogram Designer
Custom Monogram designs may be created using the Monogram 

Designer dialog. Open this dialog by going to the Home tab, and 

clicking the Monogram Designer  tool. To close the Monogram 

Designer dialog, click the OK button to generate the design, or the 

Cancel button to return to the main workspace without adding a new 

monogram.

Layout of the Monogram Designer
The various areas of the Monogram Designer dialog have different 

functions. The following illustration identifies the parts of the dialog; 

these terms are useful to remember, since they will be used 

throughout the sections that follow.

Schematic guide to the parts of the Monogram Designer dialog: A= Monogram 
styles area, B= Preview panel, C= Text area, D= Color change swatches, E= Font 
area, F= Height field, G= Status bar, H= Template buttons 
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Creating a Monogram
Creating a custom, decorated monogram design is very easy with the 

Monogram Designer. Simply select one of the monogram layouts, type 

in the letters you want, choose a font and thread color, and click the 

OK button. The basic monogram will appear in your workspace, after 

which, you can save it to the appropriate file type. You can opt to 

output the monogram either as stitches or as artwork.

You can also add embellishments to the monogram using the 

“Monogram Designer” dialog. For details, see the following sections, 

“Adding Decors to a Monogram” and “Adding a Frame to a 

Monogram”.

To create a new monogram design:

1 In the Monogram Designer dialog, select one of the styles from the 

monogram styles area.

2 In the Text area, type your lettering into the appropriate text field.

3 (Optional) In the category drop-down list, select the font category 

you want to select from (e.g. Script fonts, Run fonts, etc.). This will 

limit the list that opens in the Font field (below) to only the fonts in 

that category.

4 Select the desired font from the Fonts drop-down list.

The number of text fields that are active depends on the monogram 
style you have chosen - “Text1” will be active when a single-letter 
monogram pattern, “Text 1” and “Text 2” when a two-letter style is 
chosen, and all three fields if a three-letter style is selected.

For Name-type templates, both the “Text 1” and “Text 2” fields will be 
active - the initial letter will be input into “Text 1” and the name portion 
will be input into “Text 2”. The exception to this is the “Name-only” (i.e. 
no initial) template. For this template type, the text for the name will be 
entered in the “Text 1” Field. 

Also note that, for the Name template monogram styles, the maximum 
number of characters that the name field can have is 30.
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5 If desired, change the height of the font by typing a new value into 

the Font Height field of the dialog.

6 By default, the monogram lettering will be generated with a satin 

fill; however, you can change to a pattern fill by checking the 

Pattern Fill box in the dialog.

7 Add Decors and/or a Frame, if desired.

For more details on adding Decors and Frames, see the 
corresponding sections, below.

8 Click Apply to see your changes in the preview panel.

9 When all your changes have been made, click OK.

The design appears in the workspace.

For “Name Template” monogram styles, there will be two Height fields 
- ‘Font 1 Height’ to change the height of the monogram lettering, and 
‘Font 2 Height’ to change the height of the name.

Again, there is an exception for the “Name only” style - in this case the 
height of the name will be controlled by the ‘Font 2 Height’ field.

Each font has maximum and minimum recommended heights; for best 
quality on sew-out, you should stay within these limits.

If you enter a font height that is outside of the recommended range, a 
warning dialog will appear when you click the Apply button. This dialog 
will advise you to change (increase or decrease, depending on whether 
you are below the minimum or above the maximum) the font height 
until it is within the recommended range for that font. 

For “Name Template” monogram styles, there will be two Pattern fill 
check-boxes active in the dialog; check Font 1 Pattern Fill to change the 
monogram lettering to a pattern fill, and Font 2 Pattern Fill to change 
the “name” portion to a pattern fill.

If the “Name only” template type is being applied, the Font 1 Pattern Fill 
box will apply to the “name” text.
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Viewing the Design’s Actual Size
By default, the design’s preview in the Monogram Designer dialog will 

be scaled such that it fills the entire preview panel. This means that 

the apparent size of the lettering will change as you add or remove 

frames or decors. 

If you want the preview panel to display the design actual size instead, 

check the “1:1” box at the bottom of the Monogram Designer dialog. 

The size of the design in the preview panel will be based on the 

lettering height chosen, and will not change when decors and/or 

frames are added or removed.

Changing colors in a Monogram
In the Monogram Designer dialog, the lettering will have a default color 

to start out with. Using the Import Color function, you can change this 

color to whatever suits you, based on a list of manufacturers’ thread 

color tables. The Import Color function can be applied to each letter in 

the monogram separately, should you want to have your letters sewn 

in different colors.

To change the color of letters in the Monogram:

1 To the right of each letter, in the text area of the dialog, there is a 

colored square (the “color swatch”) - this shows the current thread 

color. Click in this square.

You see the Import Color dialog.

Note that the actual size of monogram - width and height - will always 
be displayed in the lower-left corner of the Monogram designer dialog.
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2 Select a new color palette (if desired) by clicking the down arrow to 

the right of the Color Palette Name list.

The new list of thread colors appears in the dialog.

3 Choose a thread color from the selected palette by clicking one of 

them.

4 Click Select.

The Import Color dialog closes, and the swatch changes to the color 
you have selected

5 On the Monogram Designer dialog, click Apply.

In the Preview panel, the letter will change to the color you chose.

You can search for a particular color within the Color Palette you have 
chosen, if you know its name.

To do this, click the find  button in the Import Color dialog. This 
opens another small dialog, the Find Color dialog. Type the first few 
letters of the name of the color you are looking for into the box, and the 
Find dialog will display a list of colors that match those initial letters. 
Alternatively, you can type in the thread number, and the Color Find 
tool will locate the thread by number. Then, click the color you want in 
the list; this will select that color in the Palette.
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Changing the Font
You can also change the font of the monogram lettering in the 

Monogram Designer dialog. Use any one of a large selection of 

digitized embroidery fonts that come with the BES Blue embroidery 

software.

To change the font:

1 In the Font area, click on the down-arrow next to the Font 1 list.

A drop-down list of all the available fonts appears. As you “hover” 
the mouse pointer over each font’s name, you see a sample of the 
highlighted font.

2 On the drop-down list, select the desired font by clicking on it.

3 Click Apply.

The monogram lettering changes to the selected font.

Note: Name Template Monogram Styles

For the Name Template monogram styles, there are two separate 

lettering segments – the single-letter monogram in the background, 

and the multi-letter text in the foreground. 

For these styles, it is possible to choose a different font for each part 

of the text; the ‘Font 1’ box determines the font of the single letter, and 

the ‘Font 2’ box determines the font of the multi-letter part. Choose 

your second font in exactly the same way as outlined above for 

changing ‘Font 1’.

Just below the text input area of the dialog, there is Category field, 
which allows you to select a particular font category to select from. 
Choosing a font category here will limit the drop-down list so that it 
shows only the fonts in that category.
For more information, see “Learning About the Workspace—Font 
Categorization.”
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Also, in the case of the Name Template monograms, two different 

Letter height boxes will be active, so that the font height for the “name” 

part may be set separately from the font height for the monogram 

itself.

Similarly, there will be two separate “Pattern fill” check boxes; check 

Pattern Fill1 to add a pattern to the monogram, and Pattern Fill 2 to 

add it to the “name” portion.

An example of a Name Template style, to demonstrate the use of two different fonts. 
In this example, “Venezia” was selected for Font 1, and “Calligraphy” was selected 
for Font 2.

Displaying a Font’s Available Characters
In the Monogram Designer dialog there is a button next to each of the 

font fields which displays all the characters (keystrokes) that can be 

entered for the selected embroidery font. For example, some fonts 

only allow you to enter uppercase characters, while other fonts allow 

you to enter both uppercase and lowercase characters. 

The available characters box also tells you the minimum and maximum 

recommended heights for sewing out the font.

To display a font’s available keystrokes:

1 Open the Monogram Designer dialog. 

The “Name only” template type is an exception to these rules: for this 
template, only the Text 1, Font 1, Font 1 Height and Font 1 pattern fill 
boxes will be active, and these will apply to the “Name” text. 
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2 In the Font1 or Font2 field, select the desired font from the drop-

down list. 

3 Click on the available characters button  to the immediate right 

of the font field.

You see a window that displays all the available keystrokes that you 
can enter for the selected font.

4 Click the OK button to dismiss the available characters dialog.

Adding Decors to a Monogram
In the Monogram Designer dialog, you can add small decorative 

designs, called decors, to embellish your Monogram. There are eight 

possible positions where you can place decors in the dialog preview 

panel; these are indicated by the small placeholder graphics, which 

look like this: .

To add Decors to your Monogram:

1 Click on the placeholder position where you wish to place the first 

decor.

The column on the right of the dialog changes to show a list of 
available decors.

Note that both Decors and Frames can be added to the same 
Monogram design.
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2 Click on the decor you want to add.

The selected decor appears in the monogram preview panel.

3 Adjust the decor by doing the following (these are optional):

 Change the size of the decor by typing a percentage into the 
scale box.

 Check the Flip horizontal box.

 Check the Flip vertical box.

4 Repeat steps 1–3 to add more decors in the other positions.

5 When you have added all the decors required, click OK.

The completed design appears in the workspace.

You can also make these changes - that is, flip or scale the individual 
decors - after you have added all the decors you want. Do this by 

selecting them individually with the Select  tool.

If you want to add the same decor design more than once, select and 
place first decor as described above. Then, hold down the CTRL key 
while clicking the next placeholder; the Monogram Designer will retain 
your original selection and apply it to all subsequent placements.
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Note: Monogram Designer Preview

The arrangement of lettering and frames in a design will be affected by 

any decors that are placed into it. When the monogram is generated, it 

will be centered and will fit tightly within the frame, ignoring any 

“unused” decor positions.

This will be relevant if, for example, a decor is placed on one side of 

the monogram, and not on the other. In such a case, the preview in the 

Monogram Designer will not look exactly the same as when it is 

generated in the main Workspace window, since it is still taking into 

account the decor placeholders.

So, in order to preview the design as it will generate, place the decors 

you want, and then uncheck the Decors box. This will remove any 

unused placeholders, and change the preview to show all the 

elements of the design correctly arranged. 

Above, a the preview of a design with the “Decors” box checked; below, the same 
design with the box unchecked. Note how the letters in the monogram have shifted 
up and to the right (relative to the frame), because the decors placeholders have 
been removed. This correctly reflects the actual arrangement of the design objects 
when stitches are generated.

You can also check the 1:1 box to show the lettering, frames 
and decors in actual size.
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Adding a Frame to the Monogram
You can enhance your monogram design by adding a decorative frame 

to it. Select the frame from a long list of embroidery designs that are 

included with the BES Blue software. You will see previews of these 

frames in the pane on the right side of the Monogram Designer dialog.

To add a frame to the monogram design:

1 In the preview panel of the Monogram Designer dialog, click on the 

Frame placeholder to select it.

The list of available frames appears in the column to the right of the 
dialog.

Note that both Decors and Frames can be added to the same 
Monogram design.
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2 Click on one of the frames to select it.

The selected frame will appear in the preview panel of the dialog. If 
you wish, you can click through a number of different frames to 
preview them.

3 Click OK to create the design.

The Monogram, with the selected Frame added, will now appear in 
the BES Blue design workspace.

Monogram Templates

Saving a Monogram Template

The “Save Template” option is very useful if you are going to be 

creating a number of designs that are very similar; for example, if you 

are going to make some designs that have exactly the same pattern of 

decors, but with different people’s initials in the middle. You can select 

the monogram style, font, and decors saving this pattern as a template 

for later use. Then, when you want to make a new monogram, you can 

open the template and change only the letters.
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To save as a template.

1 Open the Monogram Designer dialog.

2 Create a new monogram design as usual, but do not press OK 

when you are finished.

3 Select the “Save Template” button.

You see a “Save as” dialog box.

4 In the “Save as” dialog, choose a destination folder for the 

template, and type a name in the File name field.

5 Click Save.

Applying a Monogram Template

When you want to use one of your saved templates in Monogram 

Designer, do the following.

To use a monogram template:

1 Open the Monogram Designer dialog.

2 Click the Open Template button.

You see an Open dialog.

3 In the “Look in” field, navigate to the folder containing your saved 

templates.

4 Choose a template, and click “Open”

The template opens in the Monogram Designer dialog.

5 Make any necessary alterations to the design, for example, the 

initials in the monogram, the color of the letters, etc.

6 Click OK.

The new design appears in your workspace.

Working with Name Drops
Name Drops allow you to create a model to make a number of similar 

designs. In a template, each lettering or design segment is treated as 

a unit that can be replaced. For example, a lettering segment can be 

changed so that it uses a different font or text, but the segment 

appears in the same place as the model.
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(An example of an application for the Name Drops tool might be to 

create T-shirts for each player on a sports team; instead of creating a 

separate design for each T-shirt, use Name drops to create each shirt 

using the same logo design, but with a different name.) 

Each design that will be generated by the tool will have its own row in 

the dialog, displaying the text, the font, the font height, and the 

alignment of the lettering. Add a new row for each separate 

embroidery design you need.

To use the Name Drops Wizard: 

1 Create the design you want to use as a basis for the Template; 

using one of the text tools, include some “placeholder” text in the 

design.

2 Save the design.

3 On Home tab, click on the Name Drops  icon.

You see the Name Drops dialog.

The Name Drops will only work with files that contain only a single text 
segment.

However, if you want to use a file that already has a text segment in it, 
you can get around this constraint by converting the original text to 
stitches. Select the text, right-click, and choose “Preserve as stitches” 
from the context menu. You can then add a new text segment to the 
design, and that will be the one that varies in the Name Drops Wizard.
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4 In the Output directory box, browse to the folder to use as the 
destination for the generated files.

5 In the Base filename field, enter a name to use as the basis for the 
designs generated by the Name Drops wizard. When the files are 
generated, the file names they will be given will consist of the Base 
name, plus a sequential two-digit number - e.g. team 01.brf, 
team02.brf, team03.brf, etc

6 From the radio buttons in the dialog box, select the behavior of the 
Name Drops tool after generating the new files.

 Open all files: Each file will open (in its own tab) in the 
workspace.

 Open first file: Only the first of the files will open.

 Do not open files: The files will be generated, but not opened. 

7 To output the generated files in your choice of stitch format, do the 

following:

 Click the Save formats  button in the Name Drops dialog.

The Formats dialog opens.
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 Check the box (or boxes) next the formats (*.BRF, *.FCM, or 
*.SVG) that you want to save.

If you choose more than one format, a separate file will be 
generated for each format.

 Click Okay.

The Formats dialog will close; the select format (or formats) will 
be listed in the Name Drops dialog beside “Save formats.”

8 To add new rows to the Name Drops table, do the following:

 Click the “Add Name” button .

A new row will appear in the Name Drop table, with the Text field 
already selected.

 Type the next name in the field. 

 Repeat the above until all lines have added.

 You can remove a row by clicking the “Remove name”  
button.

9 In the text column of the table, enter the text needed for each 
design.

10 If required, make any of the following modifications to settings in 
the table by double-clicking the appropriate cell:

 Choose a new font for the text.

 Change the height of each name individually. 
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 Change the Alignment in the Align cells (left, right, center).

11 Click Save to create the files.

The specified files will be generated, and saved to your destination 
folder.
Depending on which setting you chose in step 6, one or all of the 
files will open in your workspace.

To view these changes as they look in the context of the design, 
select a column by clicking on it, and then click the Preview button 
in the final column.
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Arrange on Path
Arrange on Path is a design tool that may be applied to both lettering 

and added design segments. This tool adds a number of repeated 

design elements along the selected path shape.

Use the settings in the Arrange on Path Design dialog box to change 

the characteristics of the pattern you want to create.

Creating a pattern with the Arrange on Path Tool:

1 Select a lettering or design segment.

2 On the Tools tab, click the Arrange on Path  tool.

The Arrange on Path dialog box appears.

3 To select the desired Path shape, choose the path you want from 

the drop-down list at the top of the dialog.

A preview of the design on the path will appear in the small preview 
panel.

Arrange on Path displays the output size of the design you are creating 
in the lower right-hand corner of the dialog. These dimensions (width × 
height) are updated as you adjust any settings in the dialog that affect 
the design’s size.
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4 Make adjustments to one or more of the following: 

 To change the size of the Arrange on Path pattern as a whole, 
type the desired size in either the Width or Height boxes of the 
Path dimensions section of the dialog.

 In the Align area, choose the desired alignment for the 
individual design units on the path: either Center, Top, Bottom, 
or Alter. These settings refer to the orientation of the units 
relative to the path (see illustrations).

 In the Align area, Check the Reflect box to reflect the individual 
design units across the path.

 In the Properties area, adjust the size of the individual units by 
typing a value in the Length box.

 In the Properties area, adjust the space between individual 
units by entering a value in the Spacing box.

 The Color sort feature automatically applies the color sort 
function to the design when stitches are generated. This box is 

The “Keep aspect ratio” box in the dialog is checked by default; this 
ensures that the shape of the path stays the same as you resize it. If 
you want to stretch the shape horizontally or vertically, uncheck the 
“Keep aspect ratio” box and change the path dimensions. 
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checked by default, but if you want the colors NOT to sort, 
uncheck the Color Sort box.

5 Click Apply to preview the changes that you have made in the 

Preview pane.

6 Click OK to place the Arrange on Path in your current design page.

Arrange on Circle
The Arrange on Circle tool generates a circular pattern based on the 

selected lettering or added design segments. Use the settings in the 

Arrange on Circle Design dialog box to change the characteristics of 

the pattern you want to create. 

Creating a pattern with the Arrange on Circle Tool:

1 Using the Select tool, select the object that you want to copy.

2 On the Tools tab, click the Arrange on Circle  button.

The Arrange on Circle dialog box appears.

Sorting colors helps you minimize the number of thread changes in a 
design, by organizing the sewing order so that, where possible, all of 
any one color is sewn at the same time. 
For more information, see “Using the Color Sort Tool.” 

Note that the scale of the design in the preview window will change with 
the overall size of the Arrange on Path, allowing the whole design to fit 
into the window. 

The overall size of the design displayed as the “Output Size” at the 
bottom-right corner of the dialog.
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3 In the Arrange on Circle dialog box, do one or more of the 

following: 

 To change the size of the Arrange on Circle pattern as a whole, 
type the desired size in either the Width or Height boxes of the 
Dimensions section of the dialog.

 In the Objects section, change the number of times the seg-
ment repeats by inputting a new value in the Count field.

 In the Objects section, adjust the angle between each segment 
by typing a new value in the Angle field.

In the Design properties area, change the size of the repeated 
segments in the template by changing the percentage Scale box.

 In the Design properties area, adjust the orientation of the 
individual segments by typing a new value in the Angle box. 

 Auto rotate (on by default). Auto rotate means that each 
individual design elements will be angled to follow the curve of 
the circle.

To change the shape of your Arrange on Circle to an ellipse, 
uncheck the “Keep aspect ratio” box, and type in new values in the 
width or height boxes of the Arrange on Circle Properties section.
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To arrange them all at the same angle, uncheck the “Auto 
rotate” box.

 Color sort (on by default). The Color sort feature automatically 
applies the color sort function to the design when stitches are 
generated. If you want the design NOT sorted by color, 
uncheck the Color Sort box.

 Check Reflect to reflect the individual design units across the 
circle.

4 Click Apply to preview the changes that you have made in the 

Preview panel.

5 Click OK to place the Arrange on Circle in your current design.

Arrange on Corner
The Arrange on Corner tool may be applied to lettering and added 

design segments. When this tool is applied, a four-fold copy of this 

selection will be created, with the reproduced sections flipped on the 

vertical and horizontal axes.

In the Arrange on Corner dialog there are also settings for changing 

the vertical and horizontal separation between the units, and the angle 

of each units.

To create Arrange on Corner design:

1 Using the Select tool, select the text or design object that you want 

to copy.

Auto rotate on Auto rotate off
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2 On the Tools tab, click the Arrange on Corner  tool.

You see the Mirror dialog in front of the workspace; the selected 
segment is displayed in the Preview window.

3 In the Arrange on Corner dialog, adjust any of the following:

 In the Horizontal distance field, input a value for the amount of 
horizontal separation required.

 In the Vertical distance field, input a value for the amount of 
vertical separation required.

 In the angle field, enter the angle of displacement from the 
horizontal.
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4 To preview how the above settings will affect the appearance of the 

final design (before generating the stitches) click the Apply button.

5 (Optional) To resequence the overall design so that colors are 

placed consecutively, check the Color Sort box.

6 When all adjustments have been completed, click OK.

The completed design will appear in the workspace.

Using the Arrange Rows Tool
The Arrange Rows  tool takes the selected design object and 

makes copies, which are arranged in a regular pattern of rows and 

columns in the workspace. 

In the Arrange Rows dialog, you control the number of times the 

design element repeats (vertically and horizontally), and the 

separation between them. 

There are also options that allow you to modify the final design. You 

may include a percentage offset for alternate objects, add a 

percentage offset between every other row in the design, or flip the 

objects vertically or horizontally.

To use the Arrange Rows tool:

1 Select a design element (embroidery or artwork) in the design 

workspace.

2 On the Tool tab, click the Arrange Rows  tool.

You see the Arrange Rows dialog.

Notice that the size of the original pattern and the size the final design 
will be are shown in the dialog immediately beneath the Preview pane.
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3 In the Settings area, set the number of repeats of the selected 

object.

 Enter the number of horizontal repeats in the Number across 
field.

 Enter the number of vertical repeats in the Number down field.

4 Enter the desired distance between objects, horizontally and 

vertically, the Horizontal distance field and the Vertical distance 

field.

5 In the options area of the dialog, choose any of the following:

 Check Distance between centers to determine the Horizontal 
and Vertical separations between objects based on the center 
of the template object, rather than the extremities.

 To resequence the overall design so that colors are placed 
consecutively, check Auto resequence by color.

 Check Offset every other to add extra separation between 
every other object in the final design; enter the percentage 
(based on the size of the original object) in the percent field.
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 Check Offset every other row by to offset alternate rows in 
the final design. Enter the percentage to offset by (based on 
the size of the original object) in the percent field.
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 Check Flip every other horizontally to flip every other object in 
the design in the horizontal direction.

 Check Flip every other vertically to flip every other object in the 
design in the vertical direction.
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6 Click Apply.

You see your changes reflected in the Arrange Rows dialog’s 
preview window.

7 Click OK

The repeated design will be generated, and will appear in the 
workspace.

Creating a Scatter Design
The Scatter Design feature uses a selected design element and 

scatters copies of it randomly in the design workspace. You can create 

your Fling pattern by applying it to the whole design, or just one 

element of the design.

To use the Scatter Design tool:

1 Select a design, or some part of a design.

2 On the Tools tab, select the Scatter Design  tool.

The Scatter Design dialog opens.

You can repeat steps 3-6 until you get the look that you want, before 
actually generating the stitches for the design.

The Scatter Design dialog displays the output size of the design you 
are creating in the lower right-hand corner of the dialog. These 
dimensions (width × height) will be updated when you adjust any 
settings in the dialog that affect the design’s size.
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3 In the Template Size area of this dialog, enter the size of the area 

you want to cover in the height and width fields.

4 In the Design Properties area, make any of the following 

modifications:

 Change the minimum and/or maximum scale of the individual 
design elements that will be used to fill the area (the Scatter 
Design tool will make some instances smaller or larger to best 
fill the space). The maximum and minimum sizes are expressed 
as a percentage of the original size of the element. 

 Adjust the minimum (closest) spacing between the design 
elements.

 Auto Rotate (on by default): When set, allows the tool to rotate 
the design elements randomly within the Fling. Uncheck this 
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box to force the designs to all be placed with the same 
orientation.

 To resequence the overall design so that colors are placed 
consecutively, check Auto resequence by color.

5 Click the Apply button.

A preview of the resulting design is displayed in the dialog box.

6 Click OK.

The Scatter Design will appear in your design.

Auto rotate option on Auto rotate option off

You can repeat steps 2-5 until you get the look that you want, before 
generating the segments.

Also, each time the Apply button is clicked, the Fling tool’s 
randomization will be re-done; so, if you are not satisfied with the 
particular arrangement of the objects the first time, try hitting Apply 
again until you get one that you like better.
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Word Collage

The Word Collage  tool is a special type of text tool that generates 

a number of words, or text paths, and puts them into the design. The 

text paths are scattered randomly around within the boundaries of an 

envelope shape, which you select from the dialog. 

Use the dialog to set other parameters of the collage, such as the 

maximum number of text paths that will be included, the font used, the 

orientation of the text, etc.

The Word Collage dialog also has a preview window, which allows you 

to get a picture of how the collage will appear, before you actually 

place it in your design. This allows you to adjust settings, and re-

generate the Word Collage as often as required to get the right result.

To use Word Collage:

1 Open a new design file.

2 From the tools tab, select the Word Collage  tool.

You see the Word Collage dialog.
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3 In the Shape area, do the following:

 Select one of the outline types from the drop-down list:

 Artwork: The outline shape (envelope) will not have any 
stitches, but it will appear in the final design as an artwork 
object.

 Run: The envelope shape will be converted to Single run 
stitches. 

 Satin: The envelope shape will be converted to satin border 
stitches

 Enter the overall dimensions (height and width) of the Word 
Collage outline, or envelope. Clicking the up and down-arrows 
next to these fields to fine-tune the dimensions in 1 mm 
increments.

4 In the Text area, do the following:

 Enter the word (or words) you want to use into the Words field; 
if you want to have two or more words/phrases appearing 
separately in the collage, separate them by commas.

 In the Max Paths field, enter maximum number text segments 
that you want to include in the collage. 

 The text paths in the finished collage will have colors randomly 
assigned to them. You can limit the maximum number of colors 
that will be used by entering the desired value in the Max colors 
field (up to 15).

5 In the Font area, do the following:

 Select a font category from the Category drop-down list; this 
will limit the options in the font field to only the fonts that are in 

Check the “Maintain Aspect Ratio” box to scale both height and width 
proportionally when you adjust either of the dimensions.
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the selected category. Note that some fonts are not compatible 
with Word Collage (small fonts, for example), so some 
categories will not appear in the list.

 Select the font you want to use from the drop-down list.

 If not using the default height for the selected font, enter a 
value in the Height field.

6 In the Scale fields (Min./Max.) select the range of the variation in 

the height of the generated text segments. The minimum and 

maximum height will be expressed as percentages, where 100% 

equals the original font height (set in the text area, above).

7 Under Angle, choose the orientation of the text paths:

 Any: The paths will be oriented randomly, so as to best fit the 
chosen envelope.

 Horizontal: All text paths will be oriented along the horizontal.

 Vertical: All text paths will be oriented up and down.

 Diagonal: Text will be placed at a 45º angle.

8 Click Generate to see the Word Collage in the dialog’s preview 

window.

y

You can check the “3D View “check box in the upper-left corner of the 
dialog to see the Word Collage in realistic preview mode.
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Sometimes, if there are many paths in the Word Collage, the 
Generate command will take a few seconds to process; a progress 
bar located along the bottom of the preview window, will display the 
status of the stitch generation.

9 If required, adjust your shape, text, scale, and angle settings, and 

regenerate until the desired effect is achieved. 

10 When ready to place the Word Collage in the design, press OK.

The Word Collage will appear in the workspace.

It is important to note that every time you press the “Generate” button, a 
new Word Collage will be regenerated randomly, and so the resulting 
arrangement of words and colors will be different each time. The 
generated word placement is random; results will vary and all words 
may not be included.
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ScanNCut
ScanNCut is a tool which is used to assist in the creation of appliqués. 

When applied to the selected appliqué, it generates a new file, 

consisting of filled artwork segments. Each filled artwork corresponds 

to an Appliqué segment in the original design. You can then print this 

file as a hard copy, and scan it into a fabric-cutting machine. This will 

ensure that the appliqués will exactly match the shape and size of the 

appliqué segments in your design.

Use the Page preview tool to preview how the pieces are arranged on 

the page when it is printed. The artwork can be selected and moved, to 

optimize the use of space on the page. 

To use ScanNCut:

1 Create or open a design with appliqué segments in it.

2 Select the appliqué segment (or segments) that you want to print 

out and scan.

3 Click the ScanNCut  button.

A new, unnamed *.BRF file containing the Artwork segments will be 
generated, and will open in a new tab.
The new file will show each appliqué segment as a solid, filled 
artwork shape. The fill color will match on the original thread color of 
the segment.

4 Save the new file.

You can also change the orientation of the page using the Page 

Preview Offset  tool. This tool sets the location of the top-left corner 

of the page.

Note that this procedure will apply to outline (.brf) files only. For stitch 
files, there is a modified version of the procedure that must be followed; 
see “Applying ScanNCut to stitch files.”
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5 Click Page Preview . This will display the a preview of the page 

to be printed, with the appliqué artwork segments on it; the borders 

of the page will show as dashed lines.

6 Click Page Preview Offset .

The cursor changes to a cross.

7 Click in the workspace to change (if necessary) the position of the 

page to better fit the appliqué you are going to print. When you 

click, the center of the cross resets the upper-left corner of the 

page at that position.

8 Using the Select tool, drag and move the artwork segments to fit 

the page better. If required, the print area will expand to multiple 

pages (new page outlines will appear).

9 Click the Print tool to output the file for scanning.

Special note: On creating ScanNCut artwork from 
a Stitch file

When you want to create ScanNCut artwork from an appliqué in a non-

outline embroidery file (for example, an imported stitch file, such as a 

*.pes, *.vpn or *.dst), a special procedure must be followed. This 

Note that the page size displayed here will be determined by the 
current print settings; to change page size, select the Accelerator 
button, and then choose Print–Print Settings.

When printing out ScanNCut files, ensure that “Show Crosshairs” is 
not checked in the Print Preferences dialog.

You can also use the Export FCM  tool to output an FCM (Brother 
Cutter format) file. This file type can be read directly by the Brother 
Cutter machine.

Alternatively, you can use the Export SVG  tool to create an 

editable version of the image. The SVG format is a vector format, 
which means that it can be edited in vector graphics programs, such as 
Adobe Illustrator®. After editing, you can then print a copy from your 
graphics program for use in your ScanNCut machine.



230 BES Blue
procedure involves converting the first run stitch segment of the 

appliqué to a specific Brother thread color, which the ScanNCut tool 

then convert to a filled artwork segment in the regular way.

To use the ScanNCut tool with stitch files:

1 Open or import a stitch file containing an appliqué.

2 In the Color Palette, change the current thread chart to Brother 

Embroidery.

For more information, see “Working with the Color Palette–

Selecting a Thread Chart.”

3 Open the Sequence View, and select the first run in the appliqué.

4 In the thread palette, change the color of this run segment to 

Brother: Appliqué Material (100).

5 If there are more appliqués in the design, repeat steps 3-4 for each 

of the other appliqués, always selecting the first run.

6 Click the ScanNCut  button.

A new tab will open in the workspace, containing the Artwork 
segments.

7  Proceed according to the normal ScanNCut procedure, (steps 4-9 

in the previous section).

Note that the following procedure may not work in absolutely all cases; 
particularly, your results may not be correct if the run is not a closed 
shape.
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